Bug 88843 - up2date fails to download if install would fail
up2date fails to download if install would fail
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 16:03 EDT by ratness
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-15 14:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ratness 2003-04-14 16:03:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
If I specify the -d flag, up2date should download the packages (which I can 
later install by hand, after massaging the filesystem into a state to where the 
update will take).  Instead, it fails.

Version-Release number of selected component (if applicable):
up2date-3.1.23-1

How reproducible:
Always

Steps to Reproduce:
1. cram /usr to near capacity
2. up2date -d somepackages

Actual Results:  # /usr/sbin/up2date -d glibc glibc-common
[ snip ]
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
installing package glibc-common-2.3.2-27.9 needs 22MB on the /usr filesystem

Expected Results:  packages should be in /var/spool/up2date (which I confirmed 
has free space)

Additional info:
Comment 1 Adrian Likins 2003-04-15 14:05:34 EDT
Yup. Up2date is designed to only let you download packages you
can install (aka, you have space for, no unsolved deps, don't
conflict with other packages, etc)


Note You need to log in before you can comment on or make changes to this bug.