Bug 888452 - 3.1.3 missing 'rhevm' network interface on rhev-hypervisor6-6.4-20121212.1.auto1271
3.1.3 missing 'rhevm' network interface on rhev-hypervisor6-6.4-20121212.1.au...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Douglas Schilling Landgraf
Pavel Stehlik
infra network
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-18 13:14 EST by Gowrishankar Rajaiyan
Modified: 2013-02-25 21:43 EST (History)
17 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-1.1.el6
Doc Type: Bug Fix
Doc Text:
In a previous build of the Red Hat Entperise Virtualization Hypervisor (rhev-hypervisor6-6.4-20121212.1.auto1271.el6.iso), the management was named "ovirtmgmt" instead of "rhevm". This prevented any nodes that had been installed using that build from joining any clusters. The host management network is always named "rhevm", as this network is required by all clusters.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 14:07:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-12-18 13:14:00 EST
Description of problem:


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121212.1.auto1271.el6.iso
rhevm-3.1.0-32.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
Installed RHEV-H based on rhev-hypervisor6-6.4-20121212.1.auto1271.el6.iso , and on attempting to add it to RHEV-M, got the error message given below.
  
Actual results:
Host rhs-gp-srv12.lab.eng.blr.redhat.com does not comply with the cluster RHS-Cluster networks, the following networks are missing on host: 'rhevm' 

Expected results:
Addition of rhev-hypervisor6-6.4 in RHEVM is successful.

Additional info:
# cat /etc/redhat-release
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20121212.1.auto1271)

[root@rhs-gp-srv12 admin]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:25:90:93:62:4E
          inet6 addr: fe80::225:90ff:fe93:624e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:733810 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4103 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:46125971 (43.9 MiB)  TX bytes:836418 (816.8 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:114402 errors:0 dropped:0 overruns:0 frame:0
          TX packets:114402 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:17892538 (17.0 MiB)  TX bytes:17892538 (17.0 MiB)

ovirtmgmt Link encap:Ethernet  HWaddr 00:25:90:93:62:4E
          inet addr:XXX.XX.XX.XX  Bcast:XXX.XX.XX.XXX  Mask:XX.XX.XX.0
          inet6 addr: fe80::225:90ff:fe93:624e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19218 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1170 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1368018 (1.3 MiB)  TX bytes:553871 (540.8 KiB)
Comment 2 Douglas Schilling Landgraf 2012-12-18 13:43:20 EST
Patch available for review:
https://gerrit.eng.lab.tlv.redhat.com/#/c/3817/
Comment 3 Dan Kenigsberg 2012-12-19 02:37:22 EST
and that's for the recently-created rhev-3.1-6.4 branch:
https://gerrit.eng.lab.tlv.redhat.com/#/c/3823/
Comment 5 Allon Mureinik 2012-12-22 06:41:39 EST
> Patch available for review:
> https://gerrit.eng.lab.tlv.redhat.com/#/c/3817/
Acked by danken, and merged d/s.
Comment 8 Martin Pavlik 2013-02-20 06:34:04 EST
Verified on
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20130214.0.el6)
with rhevm 3.1.3 and 3.2
both work
Comment 10 errata-xmlrpc 2013-02-25 14:07:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0555.html

Note You need to log in before you can comment on or make changes to this bug.