Bug 88850 - Must have CD to install...
Must have CD to install...
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 18:08 EDT by Brad
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:21:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad 2003-04-14 18:08:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When I am installing additional packages after the initial installation, the
system prompts me for a CD. However, I make it a practice to copy all the
current RPMS into a directory on my HD. This allows me to keep the release right
up to date.  It would be good if the installer prompted me for an alternative
location like a network server or directory for the location of the required files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
    

Additional info:
Comment 1 Jeremy Katz 2003-04-14 19:31:27 EDT
You can do this with command line flags, look at the readme in
/usr/share/doc/redhat-config-packages-*
Comment 2 Brad 2003-04-14 20:25:58 EDT
But my request is to have something much more user-friendly and dynamic, like
"Browse for the files" instead of having to set arcane command-line variables.
Comment 3 Alex 2003-10-12 03:23:47 EDT
I'm trying to use 

redhat-config-packages -tree=/mnt/cdrom 

and it says that cannot find 'ree=/mnt/cdrom'. Then I tried 

redhat-config-packages -t/mnt/cdrom and I get:

bash-2.05b# redhat-config-packages -t/mnt/cdrom/
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 164, in ?
    hdlist = im.readHeaders()
  File "/usr/share/redhat-config-packages/method.py", line 776, in readHeaders
    update_method=None)
  File "/usr/share/redhat-config-packages/hdrlist.py", line 100, in __init__
    hdlist = rpm.readHeaderListFromFile(path)
rpm.error: (2, 'No such file or directory')
Comment 4 Jeremy Katz 2005-09-21 16:21:27 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.