Bug 888501 - Intermittent failure of FederationTests.test_pull_from_queue_recovery
Summary: Intermittent failure of FederationTests.test_pull_from_queue_recovery
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 3.0
: ---
Assignee: Ken Giusti
QA Contact: Irina Boverman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 19:31 UTC by Irina Boverman
Modified: 2015-01-21 12:56 UTC (History)
4 users (show)

Fixed In Version: qpid-qmf-0.22-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 12:56:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Irina Boverman 2012-12-18 19:31:05 UTC
Description of problem:

federation.FederationTests.test_pull_from_queue_recovery ................ fail
Error during test:  Traceback (most recent call last):
    File "<http://mrg2.lab.bos.redhat.com:8080/job/qpid-mrg-0.18-rhel6/ws/qpid/cpp/src/tests/python/commands/qpid-python-test",> line 340, in run
      phase()
    File "<http://mrg2.lab.bos.redhat.com:8080/job/qpid-mrg-0.18-rhel6/ws/qpid/cpp/src/tests/federation.py",> line 333, in test_pull_from_queue_recovery
      self.fail("Failed to find expected message containing 'Message %d'" % i)
    File "/usr/lib64/python2.6/unittest.py", line 316, in fail
      raise self.failureException, msg
  AssertionError: Failed to find expected message containing 'Message 6'
Version-Release number of selected component (if applicable):

Complete log is here:
http://mrg2.lab.bos.redhat.com:8080/job/qpid-mrg-0.18-rhel6/18/console


How reproducible:
Few times over 1 week.

make check

Comment 1 Ken Giusti 2013-04-17 17:51:37 UTC
I suspect I've found the problem.  The test suffers from a timing issue due to its use of auto-delete queues for the federation link.

The test attempts to destroy then recreate the queue used as the source of the queue route.  The problem with this is the queue is originally created as "auto-delete".  This allows the queue to be cleaned up automatically when the federation session closes at the end of the test.

The problem is that this test deletes, then re-creates this queue while it is being used by the federation to test federation session recovery.

If that queue recreation is done while the federation session is detaching, then the fed session detach will attempt to delete the auto delete queue.  This results in the recreated queue being deleted immediately, and the test fails.

I'll change the test to use a non-auto-delete queue, which should prevent the test queue from be deleted by the federation session teardown.

Comment 2 Ken Giusti 2013-04-17 19:48:01 UTC
Upstream fix:

http://svn.apache.org/viewvc?view=revision&revision=1469045


Note You need to log in before you can comment on or make changes to this bug.