Bug 888512 - Horizon: going to http://<host> should redirect to http://<host>/dashboard
Summary: Horizon: going to http://<host> should redirect to http://<host>/dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 2.0 (Folsom)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Derek Higgins
QA Contact: Nir Magnezi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 19:49 UTC by Yaniv Kaul
Modified: 2016-04-27 04:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-29 11:10:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:0204 0 normal SHIPPED_LIVE OpenStack 2012.2 Folsom Preview bug fix and enhancement update 2013-01-29 16:08:59 UTC

Description Yaniv Kaul 2012-12-18 19:49:07 UTC
Description of problem:
Unless we think there'll be more application sharing that HTTP server, it'd be easier to get to the admin console with just browsing to http://<host> .
This, in turn, should redirect to:
http://<host>/dashboard
or better yet:
https://<host>/dashboard

Version-Release number of selected component (if applicable):
python-django-horizon-2012.2.1-2.el6ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alan Pevec 2012-12-18 21:57:39 UTC
This could be an option in installer (Packstack), not default in /etc/httpd/conf.d/openstack-dashboard.conf

Comment 2 Derek Higgins 2012-12-19 01:56:16 UTC
Redirect is now added to installer upsream

https://github.com/fedora-openstack/packstack/commit/c2c95d67b86bec279f9fc836b3ecb12c1c7e8a3d

it is not added as an option, the puppet modules control the http server so no other applications can share the server.

Comment 4 Nir Magnezi 2013-01-16 14:10:42 UTC
Verified with: openstack-packstack-2012.2.2-0.3.dev281.el6ost.noarch

Browsing to http://hostname redirected to http://hostname/dashboard

Comment 6 errata-xmlrpc 2013-01-29 11:10:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0204.html


Note You need to log in before you can comment on or make changes to this bug.