Bug 888605 - Udev does not create a /dev entry for ethernet adapter em1
Udev does not create a /dev entry for ethernet adapter em1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 19:52 EST by Bob Goodwin
Modified: 2012-12-19 09:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 09:52:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Goodwin 2012-12-18 19:52:09 EST
Description of problem:
'udev' does not create an entry in /dev for my builtin motherboard ethernet device (em1).

The device is working correctly. 'ifconfig' command shows the device is up and running. QEMU allows full web browsing through this device (does not require a native /dev entry). Native linux internet apps won't run. I believe that this is because there is no /dev/em1 configuration. 


Version-Release number of selected component (if applicable):
udev-182-3,fc17.x86.64

How reproducible:
permanent condition. Internet apps cannot access the internet.

Steps to Reproduce:
1. unknown
2.
3.
  
Actual results:
Native Linux apps are unable to access the internet. Typical apps are Firefox, yum, date/time update, weather update, Lynx. 

There is no device configuration provided in the /dev/ directory.


Expected results:
'udev' needs to create a /dev/em1 (or other appropriate name) entry for this device.


Additional info:

Everything was working up until 12/15/12. Around that time, I received a fairly large list of software updates. I also used the GNOME 'firewall' gui app to enable samba.

According to the system log file, the kernel originally configures this device as 'eth0'. The device name is modified by biosdevname to 'em1'.

I am unable to find appropriate major/minor number info in any documentation online or I would create the /dev entry myself.
Comment 1 Harald Hoyer 2012-12-19 09:52:53 EST
Hmm.. Linux does not have device nodes for network interfaces. I am sorry. :-)

Note You need to log in before you can comment on or make changes to this bug.