Bug 888629 - Remote-viewer cannot extend 4 displays to 4 physical monitors while connecting to a guest on RHEVM
Summary: Remote-viewer cannot extend 4 displays to 4 physical monitors while connectin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 961455
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-19 03:35 UTC by Geyang Kong
Modified: 2013-11-21 08:05 UTC (History)
12 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Connect to a guest with 4 monitors. Consequence: Some guest monitors are not placed correctly on respective client monitors Fix: The rebase of virt-viewer and spice-gtk fixes several multi-monitor issues. Result: 4 guest displays appear in 4 physical monitors.
Clone Of:
Environment:
Last Closed: 2013-11-21 08:05:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Geyang Kong 2012-12-19 03:35:30 UTC
Description of problem:
  Remote-viewer cannot extend 4 displays to 4 physical monitors while connecting to a guest on RHEVM

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-18.el6.x86_64
spice-gtk-0.14-5.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-gtk-debuginfo-0.14-5.el6.x86_64
spice-gtk-tools-0.14-5.el6.x86_64
spice-vdagent-0.12.0-2.el6.x86_64
spice-gtk-python-0.14-5.el6.x86_64
spice-server-0.12.0-8.el6.x86_64
spice-glib-0.14-5.el6.x86_64
spice-xpi-2.7-22.el6.x86_64

Reproduce steps:
1. Install a windows guest on RHEVM.
2. Add 4 qxl into guest and install qxl-win.
3. Login user portal, start the guest, make sure "Pass crtl+alt+del to virtual machine","Enable USB Auto-Share", and "Open in Full Screen" have been checked.
4. Get a machine with 4 monitors.
5. Connect to the guest

Actual results:
1. Remote-viewer will throw 3rd and 4th displays into 1 physical monitor and ignored another unused physical monitor.

Expected results:
1. 4 displays appeared in 4 physical monitors.

Additional info:

Comment 1 Marc-Andre Lureau 2013-05-16 13:41:36 UTC
I can reproduce with current virt-viewer-0.5.2-18.el6_4.2

This seems to be fixed upstream, at least since 0.5.6. not sure what fixed it, but probably some of Hans multi-monitor fixes, moving to POST, add dep on rebase bug,

Comment 8 CongDong 2013-07-05 05:30:06 UTC
I can reproduce this bug:
Version:
# rpm -qa virt-viewer
virt-viewer-0.5.2-18.el6_4.2.x86_64
# rpm -qa | grep spice
spice-xpi-2.7-22.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch
spice-gtk-tools-0.14-7.el6.x86_64
spice-gtk-0.14-7.el6.x86_64
spice-server-0.12.0-12.el6_4.1.x86_64
spice-gtk-python-0.14-7.el6.x86_64
spice-glib-0.14-7.el6.x86_64
spice-gtk-devel-0.14-7.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-glib-devel-0.14-7.el6.x86_64
spice-vdagent-0.12.0-4.el6_4.1.x86_64
spice-server-devel-0.12.0-12.el6_4.1.x86_64

Steps:
As description

Result:
There are 4 forms, but the 3rd and 4th are all in the second monitor, so just can see 2 monitors with guest form, and the other 2 monirots are not used.


Verify:
version:
# rpm -qa |grep spice
spice-glib-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-xpi-2.7-22.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64
spice-gtk-0.20-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64

Steps:
As description

result:
All mirrors can display well

Comment 10 errata-xmlrpc 2013-11-21 08:05:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.