Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 888712 - cannot ssh into instance booted from cirros rootfs image
Summary: cannot ssh into instance booted from cirros rootfs image
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 2.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Yaniv Kaul
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-19 09:59 UTC by Eoghan Glynn
Modified: 2013-07-04 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 16:04:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eoghan Glynn 2012-12-19 09:59:41 UTC
Description of problem:

We cannot ssh into an instance booted from the cirros rootfs image.

Also the console-log is reported empty, even though libvirt reports the domain state as running.
 

Version-Release number of selected component (if applicable):

$ rpm -qa | grep nova
openstack-nova-2012.2.1-2.el6ost.noarch
python-nova-2012.2.1-2.el6ost.noarch
openstack-nova-cert-2012.2.1-2.el6ost.noarch
openstack-nova-objectstore-2012.2.1-2.el6ost.noarch
openstack-nova-scheduler-2012.2.1-2.el6ost.noarch
openstack-nova-network-2012.2.1-2.el6ost.noarch
openstack-nova-console-2012.2.1-2.el6ost.noarch
openstack-nova-compute-2012.2.1-2.el6ost.noarch
openstack-nova-novncproxy-0.4-2.el6.noarch
python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.1-2.el6ost.noarch
openstack-nova-volume-2012.2.1-2.el6ost.noarch
openstack-nova-api-2012.2.1-2.el6ost.noarch


How reproducible:

100%


Steps to Reproduce:

1. wget https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-rootfs.img.gz

2. gunzip cirros-0.3.0-x86_64-rootfs.img.gz

3. IMAGE_ID=$(glance image-create --name "cirros-rootfs2" --public --container-format ami --disk-format ami < cirros-0.3.0-x86_64-rootfs.img | grep id | awk '{print $4}')

4. nova boot --image $IMAGE_ID --flavor 1 root

5. IP_ADDR=$(nova list | grep root | awk '{print $8}' | sed 's/.*=//')

6. ssh cirros@$IP_ADDR


Actual results:

$ ssh cirros@$IP_ADDR
ssh: connect to host IP_ADDR port 22: No route to host


Expected results:

$ ssh cirros@$IP_ADDR
cirros@IP_ADDR's password:

Comment 2 Eoghan Glynn 2012-12-19 17:27:48 UTC
Turns out this was pilot error .. the cirros rootfs image is not directly bootable, but instead needs a kernel and ramdisk. So the corresponding kernel_id and ramdisk_id properties need to be specified when creating the image.

However, it does expose a legimate issue that the attempt to boot with a non-bootable image should fail in a more obvious way than just complete silence in the console log.


Note You need to log in before you can comment on or make changes to this bug.