Bug 88874 - Wrong priority for artsd in top
Summary: Wrong priority for artsd in top
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-15 08:09 UTC by Alexander Popov
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 16:35:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Popov 2003-04-15 08:09:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The PRI section in top shows wrong priority for artsd: 18446744073709551565. I'm not sure if the problem is in the kernel, artsd or psutils. These are the versions of these packages on my system:
arts-1.1-7
kernel-2.4.20-9
psutils-1.17-19


Version-Release number of selected component (if applicable):
arts-1.1-7

How reproducible:
Always

Steps to Reproduce:
1. Simply run top and see the PRI column for artsd
2.
3.
    

Additional info:

Comment 1 Michael Lee Yohe 2003-04-15 14:40:54 UTC
The package which contains the "top" command is procps.

$ rpm -qf `which top`
procps-2.0.11-6

"psutils" is a package that contains utilities for PostScript documents.

Have you restarted the daemon and noticed the behavior is consistent (the value
is the same no matter what)?  Did you upgrade to 9 or did you do a fresh install?

Comment 2 Alexander Popov 2003-04-15 15:30:51 UTC
Sorry about psutils - my mistake ("dummy mode on" I guess)...

procps is 2.0.11-6 but I doubt the problem is in it...
I killed the daemon and started it manually - the priority was OK: 15
The situation repeats when I start X via "startx" though.
I made a clear install of 9 (didn't upgrade)...

Regards,
Sasho

Comment 3 Ngo Than 2003-10-23 10:03:28 UTC
it looks like a bug in procps and probably was fixed in 2.0.11-7 or newer.

Comment 4 Alexander Larsson 2003-10-24 09:04:03 UTC
Yes, this is the negative prio thing. It should be fixed in rawhide.

Comment 5 Alexander Popov 2003-10-24 10:24:51 UTC
Thank you guys...
Should I change the status of this bug to resolve ( RAWHIDE )?

Comment 6 Alexander Larsson 2003-10-24 10:49:02 UTC
if you've verified it fixed, yes.



Note You need to log in before you can comment on or make changes to this bug.