Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 888777 - nss 3.13.6-2 and nspr-4.9.2 = VirtualBox does not work + (probably) problems with Qt programs, like K3B, QGIS
Summary: nss 3.13.6-2 and nspr-4.9.2 = VirtualBox does not work + (probably) problems ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nss
Version: 16
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-19 13:13 UTC by Adam
Modified: 2013-02-13 14:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 14:18:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam 2012-12-19 13:13:19 UTC
Description of problem:

After installing the newest "firefox 17.0.1" VirtualBox 4.1 (i don't have the package now) or 4.2 (VirtualBox-4.2-4.2.4_81684_fedora16-1.i686) does not work, and I "feel" that K3B (k3b-2.0.2-5.fc16.i686) and QGIS 1.7.4 (qgis-1.7.4-1.fc16.i686) sometimes hangs, when they are "working hard". I dont use KDE, but it's maybe problem with Qt programs after installing the newest "firefox 17.0.1".
After "yum remove firefox", "yum remove xulrunner" the problem still appeared.

With the newest "firefox 17.0.1" came nspr and nss like below:

Version-Release number of selected component (if applicable):

Updated: nspr-4.9.2-1.fc16.i686
Updated: nspr-devel-4.9.2-1.fc16.i686
Updated: nss-util-3.13.6-2.fc16.i686
Updated: nss-softokn-freebl-3.13.6-2.fc16.i686
Updated: nss-util-devel-3.13.6-2.fc16.i686
Updated: nss-softokn-freebl-devel-3.13.6-2.fc16.i686
Updated: nss-softokn-3.13.6-2.fc16.i686
Updated: nss-softokn-devel-3.13.6-2.fc16.i686
Updated: nss-sysinit-3.13.6-1.fc16.i686
Updated: nss-3.13.6-1.fc16.i686
Updated: nss-devel-3.13.6-1.fc16.i686
Updated: nss-tools-3.13.6-1.fc16.i686


Additional info:

I've downgraded those to the last, what I had before:
nspr-4.9-1.fc16.i686.rpm
nspr-devel-4.9-1.fc16.i686.rpm
nss-3.13.3-1.fc16.i686.rpm
nss-devel-3.13.3-1.fc16.i686.rpm
nss-softokn-3.13.3-1.fc16.i686.rpm
nss-softokn-devel-3.13.3-1.fc16.i686.rpm
nss-softokn-freebl-3.13.3-1.fc16.i686.rpm
nss-softokn-freebl-devel-3.13.3-1.fc16.i686.rpm
nss-sysinit-3.13.3-1.fc16.i686.rpm
nss-tools-3.13.3-1.fc16.i686.rpm
nss-util-3.13.3-2.1.fc16.i686.rpm
nss-util-devel-3.13.3-2.1.fc16.i686.rpm

...and problems disapeared.
After that I've installed Firefox from original Mozilla site - still no problems. I use the newest version of VirtualBox, like You see. I can't use the newest QGIS, becouse it has errors (not technical, but essential errors).

Comment 1 Elio Maldonado Batiz 2012-12-19 16:47:07 UTC
I didn't test with VirtualBox as KVM is what we ship on Fedora. I understand that VirtualBox may be your only viable option with older systems. On older i686-based systems without the hardware support for virtualization and VirtualBox may be the only way.

An update to 3.14 should appear in f16 updates-testing in a few days. The update set you were using, as explained in the notes, was intended to be a short-lived set for bootstrapping your system to prevent any possible conflicts when updating nss/nss-softokn/nss-util to 3.14. I had run into some install conflicts while testing as some headers moved around and ended in different -devel packages causing such conflicts. I pushed that set as a precautionary update to spare folks any pains. Additional testing suggests it may not be absolutely needed. The previous set would have been okay.

If you prefer to remain on the 3.13 line then the one with nss-3.13.3 you tried that worked for you is not the latest. The set just before the one where had problems using is 3.13.6 but it has -1 instead of -2. You can get it from  https://admin.fedoraproject.org/updates/FEDORA-2012-15556/nss-util-3.13.6-1.fc16,nss-softokn-3.13.6-1.fc16,nss-3.13.6-1.fc16. 

I wonder if it makes a difference. 

nss 3.14 for f16 should be showing up in a day or two and it's available now from https://admin.fedoraproject.org/updates/nss-util-3.14-1.fc16,nss-softokn-3.14-5.fc16,nss-3.14-7.fc16.

Comment 2 Fedora End Of Life 2013-01-16 13:29:09 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Fedora End Of Life 2013-02-13 14:18:29 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.