Bug 88878 - posgresql and libpq++ won't allow programs to compile
Summary: posgresql and libpq++ won't allow programs to compile
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-15 08:52 UTC by Robert Hyer
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 18:00:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compile Errors (8.19 KB, text/plain)
2003-04-15 09:06 UTC, Robert Hyer
no flags Details

Description Robert Hyer 2003-04-15 08:52:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
After installing postgresql via the RPMS's i found that lipq++.h and lipq++.so 
were missing so I was told to compile the libpq++ or libpqXX from 
http://gborg.postgresql.org. It compiled fine and i did a make install. I then 
tried to compile gnuworld which uses libpq++ and other libraries from 
postgresql. When i came to compile the libpq++.h and llibpq++.so libraries 
into the program the program came up with several errors and it exited.  

Version-Release number of selected component (if applicable):
libpq++ and postgresql 7.3.2

How reproducible:
Always

Steps to Reproduce:
1.install redhat 9.0 postgresql RPMS
2.download libpq++.zip or libpqXX from http://gborg.postgresql.org
3.untared the file did ./configure --prefix=/usr since pgsql libraries are all 
over the place
4.did a make
5. make install
6. configure gnuworld with cservice/ccontrol modules
7.make

Actual Results:  program exits

Expected Results:  program compiles 

Additional info:

I was able to compile this program on all PREVIOUS versions of redhat.  I have 
a 8.0 box which was an upgrade box from 7.X versions able to compile the 
program. I did a clean install on this box. Still I am unable to get my 
program to compile. I also have tried to install postgresql from source and 
still unable to get the libpq++ libraries to be able to compile in.  I have 
included a file of the errors to see if maybe you can assist me.

Comment 1 Robert Hyer 2003-04-15 09:06:38 UTC
Created attachment 91140 [details]
Compile Errors

This document contains the errors i get while compiling gnuworld.

Comment 2 Andrew Overholt 2003-04-16 18:00:38 UTC
I am willing to bet that this is a PostgreSQL issue involving either libpq++ and
the version of GCC on RHL 9 or a GNUWorld issue involving PostgreSQL > 7.2.1. 
According to this page
http://gnuworld.undernet.org/gnuworld-setup/?s=3&os=linux&modules=cservice+ccontrol&r=1&secure=0&subset=A-1,
their recommended version of PostgreSQL is 7.2.1.  You could try using that
version by compiling from source, but I can't guarantee anything.  Sorry I can't
help more.


Note You need to log in before you can comment on or make changes to this bug.