Bug 888783 - [abrt] libreoffice-core-3.5.7.2-7.fc17: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.7.2-7.fc17: Process /usr/lib64/libreoffice/progra...
Status: CLOSED DUPLICATE of bug 892770
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:8e83ed30f4d228f4c938d096259...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 08:28 EST by Chris Brennan
Modified: 2013-01-08 00:31 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 08:11:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (6.85 KB, text/plain)
2012-12-19 08:28 EST, Chris Brennan
no flags Details
File: environ (3.30 KB, text/plain)
2012-12-19 08:28 EST, Chris Brennan
no flags Details
File: event_log (2.86 KB, text/plain)
2012-12-19 08:28 EST, Chris Brennan
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-19 08:28 EST, Chris Brennan
no flags Details
File: backtrace (50.40 KB, text/plain)
2012-12-19 08:28 EST, Chris Brennan
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: smolt_data (2.74 KB, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: executable (42 bytes, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: maps (72.02 KB, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: dso_list (9.31 KB, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: proc_pid_status (969 bytes, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: open_fds (1.44 KB, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details
File: var_log_messages (454 bytes, text/plain)
2012-12-19 08:29 EST, Chris Brennan
no flags Details

  None (edit)
Description Chris Brennan 2012-12-19 08:28:41 EST
Description of problem:
Just started oocalc and it crashed the first time.

Version-Release number of selected component:
libreoffice-core-3.5.7.2-7.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --quickstart --nologo --nodefault
crash_function: Window::ImplGetFirstOverlapWindow
kernel:         3.6.9-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 Window::ImplGetFirstOverlapWindow at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/window/window2.cxx:1381
: #1 Window::SetParent at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/window/window.cxx:6083
: #2 framework::ToolbarLayoutManager::implts_calcWindowPosSizeOnSingleRowColumn at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/toolbarlayoutmanager.cxx:2701
: #3 framework::ToolbarLayoutManager::doLayout at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/toolbarlayoutmanager.cxx:248
: #4 framework::LayoutManager::implts_doLayout at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/layoutmanager.cxx:2447
: #5 framework::LayoutManager::implts_doLayout_notify at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/layoutmanager.cxx:2345
: #6 framework::LayoutManager::implts_updateUIElementsVisibleState at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/layoutmanager.cxx:822
: #7 framework::LayoutManager::windowShown at /usr/src/debug/libreoffice-3.5.7.2/framework/source/layoutmanager/layoutmanager.cxx:2792
: #8 WindowListenerMultiplexer::windowShown at /usr/src/debug/libreoffice-3.5.7.2/toolkit/source/helper/listenermultiplexer.cxx:85
: #9 VCLXWindow::ProcessWindowEvent at /usr/src/debug/libreoffice-3.5.7.2/toolkit/source/awt/vclxwindow.cxx:543
Comment 1 Chris Brennan 2012-12-19 08:28:45 EST
Created attachment 666065 [details]
File: core_backtrace
Comment 2 Chris Brennan 2012-12-19 08:28:46 EST
Created attachment 666067 [details]
File: environ
Comment 3 Chris Brennan 2012-12-19 08:28:50 EST
Created attachment 666069 [details]
File: event_log
Comment 4 Chris Brennan 2012-12-19 08:28:54 EST
Created attachment 666070 [details]
File: limits
Comment 5 Chris Brennan 2012-12-19 08:28:58 EST
Created attachment 666072 [details]
File: backtrace
Comment 6 Chris Brennan 2012-12-19 08:29:01 EST
Created attachment 666075 [details]
File: cgroup
Comment 7 Chris Brennan 2012-12-19 08:29:03 EST
Created attachment 666076 [details]
File: smolt_data
Comment 8 Chris Brennan 2012-12-19 08:29:04 EST
Created attachment 666077 [details]
File: executable
Comment 9 Chris Brennan 2012-12-19 08:29:12 EST
Created attachment 666080 [details]
File: maps
Comment 10 Chris Brennan 2012-12-19 08:29:15 EST
Created attachment 666081 [details]
File: dso_list
Comment 11 Chris Brennan 2012-12-19 08:29:18 EST
Created attachment 666082 [details]
File: proc_pid_status
Comment 12 Chris Brennan 2012-12-19 08:29:21 EST
Created attachment 666083 [details]
File: open_fds
Comment 13 Chris Brennan 2012-12-19 08:29:25 EST
Created attachment 666084 [details]
File: var_log_messages
Comment 14 sm301 2012-12-19 20:16:31 EST
Libreoffice crashed on startup, when I opened a text-only .odt file with it. The file was created by libreoffice in windows (XP); it was stored on the desktop folder in the windows partition of my hard drive.

backtrace_rating: 4
Package: libreoffice-core-3.5.7.2-7.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Caolan McNamara 2012-12-20 05:19:23 EST
Is this reproducible. Or is this perhaps an example of LibreOffice running during an upgrade of LibreOffice ?
Comment 16 Caolan McNamara 2013-01-07 08:11:58 EST
Can't reproduce this locally. If it persists, and is associated with a specific document, feel free to reopen if you can attach the document that triggers it.
Comment 17 David Tardon 2013-01-08 00:31:35 EST

*** This bug has been marked as a duplicate of bug 892770 ***

Note You need to log in before you can comment on or make changes to this bug.