Bug 888791 - product cert mappings for RHN Channels rhel-x86_64-server-6-rhevm-3.1* are missing
product cert mappings for RHN Channels rhel-x86_64-server-6-rhevm-3.1* are mi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
nobody nobody
:
Depends On:
Blocks: rhsm-rhel65 rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-12-19 08:42 EST by John Sefler
Modified: 2013-11-21 16:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:23:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 08:42:38 EST
Description of problem:

996         "Name": "Red Hat Enterprise Virtualization", 
997         "Product ID": "150", 
998         "RHN Channels": [
999             "rhel-x86_64-rhev-mgmt-agent-5", 
1000             "rhel-x86_64-rhev-mgmt-agent-5-beta", 
1001             "rhel-x86_64-rhev-mgmt-agent-6", 
1002             "rhel-x86_64-rhev-mgmt-agent-6-beta", 
1003             "rhel-x86_64-rhev-mgmt-agent-6-beta-debuginfo", 
1004             "rhel-x86_64-rhev-mgmt-agent-6-debuginfo", 
1005             "rhel-x86_64-server-6-rhevh", 
1006             "rhel-x86_64-server-6-rhevh-beta", 
1007             "rhel-x86_64-server-6-rhevh-beta-debuginfo", 
1008             "rhel-x86_64-server-6-rhevh-debuginfo", 
1009             "rhel-x86_64-server-6-rhevm-3", 
1010             "rhel-x86_64-server-6-rhevm-3-beta", 
1011             "rhel-x86_64-server-6-rhevm-3-beta-debuginfo", 
1012             "rhel-x86_64-server-6-rhevm-3-debuginfo", 
1013             "rhel-x86_64-server-6-rhevm-3.1",           <================
1014             "rhel-x86_64-server-6-rhevm-3.1-debuginfo"  <================
1015         ]

The 
Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.2.6-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# grep rhel-x86_64-server-6-rhevm-3.1 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-6 ~]# 
  
Actual results:
above (NO HITS FOUND BY THE GREP)

Expected results:
rhel-x86_64-server-6-rhevm-3.1: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.1-debuginfo: rhev-x86_64-64e7e55215a4-150.pem



Additional info:
Note: that this product cert for 150 currently resides in [rcm/rcm-metadata.git] / product_ids / rhev-3.1 / products / 


THE HARDER PROBLEM 1 TO BE SOLVED IS HOW TO DISTINGUISH THAT THESE CHANNELS FOR rhevm-3.1 MAP TO THE 150 PRODUCT CERTS UNDER [rcm/rcm-metadata.git] / product_ids / rhev-3.1 / products / AND NOT UNDER [rcm/rcm-metadata.git] / product_ids / rhev-3.0 /

AND THEN PROBLEM 2 IS TO REALIZE THAT IF BOTH rhev-3 and rhev-3.1 CHANNELS ARE BEING CONSUMED, THE MIGRATION SCRIPT WILL CLOBBER THE LAYING DOWN OF ONE 150.pem BY THE OTHER 150.pem.  IN MY OPINION, THE HASHES ON THE PRODUCT CERT FILES NAMES SHOULD NOT BE STRIPPED WHEN INSTALLING THEM TO /etc/pki/product
Comment 1 RHEL Product and Program Management 2012-12-24 01:55:29 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Dennis Gregorovic 2013-09-18 16:49:30 EDT
The rhevm 3.1 (and 3.2) channels are in the latest product-certs.json.

$ grep rhevm product-certs.json
    "rhel-x86_64-server-6-rhevm-3": {
    "rhel-x86_64-server-6-rhevm-3-debuginfo": {
    "rhel-x86_64-server-6-rhevm-3.1": {
    "rhel-x86_64-server-6-rhevm-3.1-debuginfo": {
    "rhel-x86_64-server-6-rhevm-3.2": {
    "rhel-x86_64-server-6-rhevm-3.2-debuginfo": {
Comment 6 John Sefler 2013-09-24 09:54:17 EDT
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.3.2-1.el6.noarch

[root@jsefler-6 ~]# grep rhevm-3 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-rhevm-3: product-x86_64-4d1f929972d7-150.pem
rhel-x86_64-server-6-rhevm-3-debuginfo: product-x86_64-4d1f929972d7-150.pem
rhel-x86_64-server-6-rhevm-3.1: rhev-x86_64-64e7e55215a4-150.pem
rhel-x86_64-server-6-rhevm-3.1-debuginfo: rhev-x86_64-64e7e55215a4-150.pem

VERIFIED: mappings for both the rhevm-3 and rhevm-3.1 channels are now included in the subscription-manager-migration-data package.

Inclusion of the new mapping for rhevm-3.2 requires a new build of subscription-manager-migration-data.  I guess we'll be opening a new bug.


PROBLEM 2 in comment 0 is being addressed by bug 1006985
Comment 7 errata-xmlrpc 2013-11-21 16:23:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.