Bug 88884 - FTP install cant find hdlist
FTP install cant find hdlist
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 06:10 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 14:43:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda.log of failed RH9 (Shrike) FTP installation (5.84 KB, text/plain)
2003-04-21 17:03 EDT, Peter van Egdom
no flags Details

  None (edit)
Description Need Real Name 2003-04-15 06:10:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
When attempting to install from a local ftp server, the procedure fails at the
stage of "Reading package information". It appears to be having problems either
retrieving or processing file hdlist.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start install using two floppies
2. Select FTP method
3. Select partitions, bootleader, network, firewall, language, timezone etc.
    

Actual Results:  Install procedes correctly, until it reaches "Reading package
information". The error message "Unable to read header list. This may be due to
a missing file or bad media. Press <return> to try again." is shown.

Accessing the alternate console via ALT-F3 shows the following error:

moving (1) to step readcomps
readheaders(): exception content-length getting content length
File ftp://192.168.1.8/9/RedHat/base/hdlist not found.

The last two lines appear five times.

Expected Results:  Install should complete

Additional info:

Installation started using two boot floppies created from bootdisk.img and
drvnet.img, using FTP install option from local server.  Note that the file does
exist on the server. I have mediachecked the cdroms that were copied to the
server and tried a fresh downloaded copy of hdlist, with the same result.

The install has been tried to two client machines (a RH8.0 desktop and a Windows
Laptop) with the same result.

The ftp server is on Windows NT (IIS 4.0 FTP service). This has been used to
host other installations (6.2->8.0) and has had no previous problem. The server
does default to ascii mode, so I wonder if that may be the problem.
Comment 1 Michael Fulbright 2003-04-15 12:37:46 EDT
Please try the update image:

http://people.redhat.com/~katzj/9-updates.img

Write this out to a floppy using the 'dd' command the same way you would make a
boot floppy.  Then boot the installer with 'linux updates' and insert the floppy
when prompted.
Comment 2 Need Real Name 2003-04-16 04:58:33 EDT
Many thanks, using the updates floppy resolves the problem.
Comment 3 Peter van Egdom 2003-04-21 17:02:14 EDT
I encountered exactly the same bug (see attached "anaconda.log" file) during
installation of Red Hat Linux release 9 (Shrike) by FTP.

Using the update image as advised in comment #1 resolved the problem for me too.
Comment 4 Peter van Egdom 2003-04-21 17:03:40 EDT
Created attachment 91209 [details]
Anaconda.log of failed RH9 (Shrike) FTP installation
Comment 5 Jeremy Katz 2003-05-13 14:43:22 EDT
The changes in that update disk are applied in CVS and will be present in our
next release.
Comment 6 wim van loo 2004-08-10 16:06:55 EDT
Hi,

I ran into exactly the same issue. Allthough i was perfectly able to 
get the file using wget (had to search for a device with sufficient 
space though because the file is about 9Mb.. 
So it is not related to the length of the ftp-path you type in in the 
beginning (because in my case it always came with a content-header-
length exception.. and the path to my install ftp is kinda long..)

just my 2 cents

Note You need to log in before you can comment on or make changes to this bug.