Bug 888858 - [ml] pofilter tabs test failed for several msgids
[ml] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 11:34 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 11:34:42 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo > /usr/share/locale/ml/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/ml/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-18 02:03-0500\n"
"Last-Translator: anipeter <anipeter@fedoraproject.org>\n"
"Language-Team: Malayalam <discuss@lists.smc.org.in>\n"
"Language: ml\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Product ID:           \t%s"
msgstr "പ്രൊഡക്ട് ഐഡി: %s"

# (pofilter) tabs: Different tabs
msgid "Product Name:         \t%s"
msgstr "പ്രൊഡക്ടിന്റെ പേരു്: %s"

# (pofilter) tabs: Different tabs
msgid "Version:              \t%s"
msgstr "പതിപ്പു്: %s"
[###########################################] 100%
[root@jsefler-6 ~]# 


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64



Additional info:
Comment 2 Ani Peter 2012-12-20 00:28:37 EST
Have updated translations with \t and committed at:
https://translate.zanata.org/zanata/iteration/files/subscription-manager/1.1.X/ml

Please have a look and let me know if all look good.

Thanks
Ani
Comment 3 Adrian Likins 2013-01-04 13:31:24 EST
fixed upstream, should be in 1.1.19
Comment 5 John Sefler 2013-01-07 16:42:16 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo > /usr/share/locale/ml/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/ml/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


[root@jsefler-6 ~]# grep -A1 "Product ID:   " /usr/share/locale/ml/LC_MESSAGES/rhsm.pomsgid "Product ID:           \t%s"
msgstr "പ്രൊഡക്ട് ഐഡി:           \t%s"
[root@jsefler-6 ~]# grep -A1 "Product Name:   " /usr/share/locale/ml/LC_MESSAGES/rhsm.po
msgid "Product Name:         \t%s"
msgstr "പ്രൊഡക്ടിന്റെ പേരു്:         \t%s"
[root@jsefler-6 ~]# grep -A1 "Version:   " /usr/share/locale/ml/LC_MESSAGES/rhsm.po
msgid "Version:              \t%s"
msgstr "പതിപ്പു്:              \t%s"



VERIFIED: pofilter tabs test are now passing
Comment 7 errata-xmlrpc 2013-02-21 04:04:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.