This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888862 - Live Snaphost: There is no validation of the DC's compatability version for a diskless VM
Live Snaphost: There is no validation of the DC's compatability version for a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.1
All All
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Maor
Dafna Ron
storage
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-19 11:45 EST by Allon Mureinik
Modified: 2016-02-10 15:12 EST (History)
8 users (show)

See Also:
Fixed In Version: sf5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11107 None None None Never

  None (edit)
Description Allon Mureinik 2012-12-19 11:45:53 EST
Description of problem:
Taking a live snapshot of a diskless VM on a 3.0 DC fails since this DC does not support the snapshot verb instead of failing "nicely" with a canDoAction message.

Version-Release number of selected component (if applicable):
si25

How reproducible:
100%

Steps to Reproduce:
1. Create a 3.0 DC ***WITH A 3.0 HOST*** on RHEV-M 3.1
2. Create a VM with no disks and boot it from network
3. Take a live snapshot
  
Actual results:
Live snapshot fail with an error message from VDSM

Expected results:
Should get a canDoAction about an unsupported operation in this DC compatability level.

Additional info:
Comment 1 Allon Mureinik 2012-12-19 11:50:22 EST
technical insight:

CreateAllSnapshotsFromVmCommand's canDoAction loads the VM's disks, and only if there are any disks, performs the relevant checks, among them the cluster compatibility level check.
This check should be pushed forward, and done before loading the disks.
Comment 2 Allon Mureinik 2013-01-20 05:02:22 EST
Maor - why did you move this bug to POST?
Can you add a change-id of a patch that solves this and/or a gerrit link?
Comment 3 Maor 2013-01-20 08:07:52 EST
Pushed upstream at http://gerrit.ovirt.org/#/c/11107/
Comment 4 Maor 2013-01-20 08:08:22 EST
Merged upstream with change id I77e301643b3ac9789cc5eb7527b6a5a4a0aac6be
Comment 6 Dafna Ron 2013-02-06 10:30:18 EST
verified on sf5

tested for 3.0 DC and cluster and a 3.0 DC and 3.1 Cluster

Error while executing action: Cannot create Snapshot. Selected data center compatibility version does not support live snaps
Comment 7 Itamar Heim 2013-06-11 04:25:47 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:26:21 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.