Bug 888864 - [es_ES] pofilter tabs test failed for several msgids
[es_ES] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2012-12-19 11:47 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 11:47:50 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo > /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-18 12:12-0500\n"
"Last-Translator: alikins <alikins@redhat.com>\n"
"Language-Team: Spanish (Spain)\n"
"Language: es-ES\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Active:               \t%s"
msgstr "Activo:   %s"

# (pofilter) tabs: Different tabs
msgid "Quantity Used:        \t%s"
msgstr "Cantidad utilizada:  %s"

# (pofilter) tabs: Different tabs
msgid "Repo Url:             \t%s"
msgstr "URL de repositorio: %s"

# (pofilter) tabs: Different tabs
msgid "Serial Number:        \t%s"
msgstr "Número de serie:     %s"
[###########################################] 100%
[root@jsefler-6 ~]# 




Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Adrian Likins 2013-01-04 13:06:35 EST
Looks to be fixed upstream

@@ -2617,21 +2620,21 @@ msgstr "Cuenta:              \t%s"
 #: ../src/subscription_manager/managercli.py:2000
 #, python-format
 msgid "Serial Number:        \t%s"
-msgstr "Número de serie:     %s"
+msgstr "Número de serie:        \t%s"

 # translation auto-copied from project Subscription Manager, version 1.0.X,
 # document keys, author gguerrer
 #: ../src/subscription_manager/managercli.py:2002
 #, python-format
 msgid "Active:               \t%s"
-msgstr "Activo:   %s"
+msgstr "Activo:               \t%s"

 # translation auto-copied from project Subscription Manager, version 1.0.X,
 # document keys, author gguerrer
 #: ../src/subscription_manager/managercli.py:2004
 #, python-format
 msgid "Quantity Used:        \t%s"
-msgstr "Cantidad utilizada:  %s"
+msgstr "Cantidad utilizada:        \t%s"


Should land in 1.1.19
Comment 4 John Sefler 2013-01-07 16:38:58 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo > /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


[root@jsefler-6 ~]# grep -A1 "Active:   " /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
msgid "Active:               \t%s"
msgstr "Activo:               \t%s"
[root@jsefler-6 ~]# grep -A1 "Quantity Used:   " /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
msgid "Quantity Used:        \t%s"
msgstr "Cantidad utilizada:        \t%s"
[root@jsefler-6 ~]# grep -A1 "Repo Url:   " /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
msgid "Repo Url:             \t%s"
msgstr "URL de repositorio:             \t%s"
[root@jsefler-6 ~]# grep -A1 "Serial Number:   " /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
msgid "Serial Number:        \t%s"
msgstr "Número de serie:        \t%s"


VERIFIED: pofilter tabs test now passes
Comment 6 errata-xmlrpc 2013-02-21 04:05:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.