Bug 888868 - [pt_BR] pofilter tabs test failed for several msgids
[pt_BR] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2012-12-19 11:58 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 11:58:09 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo > /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-16 08:02-0500\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: Portuguese (Brazil)\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Arch:                 \t%s"
msgstr "Arq: %s"

# (pofilter) tabs: Different tabs
msgid "Description:          \t%s"
msgstr "Descrição: %s"

# (pofilter) tabs: Different tabs
msgid "Enabled:              \t%s"
msgstr "Habilitado:  %s"

# (pofilter) tabs: Different tabs
msgid "Ends:                 \t%s"
msgstr "Finaliza: %s"

# (pofilter) tabs: Different tabs
msgid "Multi-Entitlement:    \t%s"
msgstr "Multi-Direitos a serviços: %s"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "Nome: %s"

# (pofilter) tabs: Different tabs
msgid "Pool Id:              \t%s"
msgstr "Id do Pool: %s"

# (pofilter) tabs: Different tabs
msgid "Product ID:           \t%s"
msgstr "ID do Produto: %s"

# (pofilter) tabs: Different tabs
msgid "Product Name:         \t%s"
msgstr "Nome do Produto: %s"

# (pofilter) tabs: Different tabs
msgid "Quantity:             \t%s"
msgstr "Quantidade: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Id:              \t%s"
msgstr "Id do Repo: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Name:            \t%s"
msgstr "Nome do Repo: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Url:             \t%s"
msgstr "Url do Repo: %s"

# (pofilter) tabs: Different tabs
msgid "SKU:                  \t%s"
msgstr "SKU: %s"

# (pofilter) tabs: Different tabs
msgid "Service Level:        \t%s"
msgstr "Nível do Serviço: %s"

# (pofilter) tabs: Different tabs
msgid "Service Type:         \t%s"
msgstr "Tipo de Serviço: %s"

# (pofilter) tabs: Different tabs
msgid "Starts:               \t%s"
msgstr "Inicia:  %s"

# (pofilter) tabs: Different tabs
msgid "Status:               \t%s"
msgstr "Status: %s"

# (pofilter) tabs: Different tabs
msgid "Subscription Name:    \t%s"
msgstr "Nome da Subscrição: %s"

# (pofilter) tabs: Different tabs
msgid "System Type:          \t%s"
msgstr "Tipo de Sistema: %s"

# (pofilter) tabs: Different tabs
msgid "Version:              \t%s"
msgstr "Versão: %s"
[###########################################] 100%
[root@jsefler-6 ~]# 



Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Glaucia Cintra 2013-01-06 23:00:31 EST
All messages above have been updated and modified in pt-BR.
Comment 5 John Sefler 2013-01-07 16:29:17 EST
Testing Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.poprocessing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2013-01-06 11:04-0500\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: Portuguese (Brazil)\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Product ID:           \t%s"
msgstr "ID do Produto: %s"
[###########################################] 100%
[root@jsefler-6 ~]# 



FAILED!
Expected:
msgid "ID do Produto:           \t%s"
Comment 6 John Sefler 2013-01-07 16:34:12 EST
(In reply to comment #5)
> FAILED!
> Expected:
msgid "Product ID:           \t%s"
msgstr "ID do Produto:           \t%s"
Comment 7 Glaucia Cintra 2013-01-07 20:14:57 EST
Message above fixed in pt-BR.
Comment 9 John Sefler 2013-01-08 16:59:52 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo > /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t tabs /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


VERIFIED: pofilter tabs test is now passing for LANG=pt_BR
Comment 11 errata-xmlrpc 2013-02-21 04:05:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.