Bug 888886 - [it] pofilter tabs test failed for several msgids
[it] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 12:37 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 12:37:18 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo > /usr/share/locale/it/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/it/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-17 06:27-0500\n"
"Last-Translator: hedda <hedda@fedoraproject.org>\n"
"Language-Team: Italian\n"
"Language: it\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "Nome: %s"

# (pofilter) tabs: Different tabs
msgid "Product Name:         \t%s"
msgstr "Nome prodotto: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Url:             \t%s"
msgstr "Url ripo: %s"

# (pofilter) tabs: Different tabs
msgid "Service Type:         \t%s"
msgstr "Tipo di servizio: %s"
[###########################################] 100%
[root@jsefler-6 ~]# 



Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Hedda Peters 2012-12-19 19:40:17 EST
Fixed in it-IT translation in https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.1.X.
Comment 5 John Sefler 2013-01-07 16:08:13 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo > /usr/share/locale/it/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/it/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


[root@jsefler-6 ~]# grep -A1 "Name:   " /usr/share/locale/it/LC_MESSAGES/rhsm.po
msgid "Name:                 \t%s"
msgstr "Nome:                 \t%s"
--
msgid "Product Name:         \t%s"
msgstr "Nome prodotto:         \t%s"
--
msgid "Repo Name:            \t%s"
msgstr "Nome ripo:            \t%s"
--
msgid "Subscription Name:    \t%s"
msgstr "Nome sottoscrizione:    \t%s"
[root@jsefler-6 ~]# grep -A1 "Repo Url:   " /usr/share/locale/it/LC_MESSAGES/rhsm.po
msgid "Repo Url:             \t%s"
msgstr "Url ripo:             \t%s"
[root@jsefler-6 ~]# grep -A1 "Service Type:   " /usr/share/locale/it/LC_MESSAGES/rhsm.po
msgid "Service Type:         \t%s"
msgstr "Tipo di servizio:         \t%s"
[root@jsefler-6 ~]# 


VERIFIED: pofilter tabs test are passing
Comment 7 errata-xmlrpc 2013-02-21 04:05:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.