This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888889 - [hi] pofilter tabs test failed for several msgids
[hi] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 12:46 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 12:46:50 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo > /usr/share/locale/hi/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/hi/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-12 04:51-0500\n"
"Last-Translator: rajesh <rajesh@fedoraproject.org>\n"
"Language-Team: Hindi\n"
"Language: hi\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Multi-Entitlement:    \t%s"
msgstr "बहुल एंटाइटेलमेंट: %s"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "नाम: %s"

# (pofilter) tabs: Different tabs
msgid "Pool Id:              \t%s"
msgstr "पुल आईडी: %s"

# (pofilter) tabs: Different tabs
msgid "Product Name:         \t%s"
msgstr "उत्पाद नाम: %s"

# (pofilter) tabs: Different tabs
msgid "Quantity Used:        \t%s"
msgstr "प्रयुक्त मात्रा: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Id:              \t%s"
msgstr "रिपो आईडी: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Name:            \t%s"
msgstr "रिपो नाम: %s"

# (pofilter) tabs: Different tabs
msgid "Repo Url:             \t%s"
msgstr "रिपो Url: %s"

# (pofilter) tabs: Different tabs
msgid "Subscription Name:    \t%s"
msgstr "सदस्यता नाम:  %s"
[###########################################] 100%
[root@jsefler-6 ~]# 


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Adrian Likins 2013-01-08 10:00:25 EST
This looks to have been fixed upstream in zanata, and is in 1.1.19
Comment 4 John Sefler 2013-01-08 15:29:16 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo > /usr/share/locale/hi/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/hi/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%
[root@jsefler-6 ~]# 


VERIFIED: pofilter tabs test is now passing for LANG hi
Comment 6 errata-xmlrpc 2013-02-21 04:05:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.