This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888891 - [zh_CN] pofilter tabs test failed for several msgids
[zh_CN] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 12:53 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 12:53:09 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo > /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-11 07:24-0500\n"
"Last-Translator: leahliu <lliu@redhat.com>\n"
"Language-Team: Chinese (Simplified, China)\n"
"Language: zh-Hans-CN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Account:              \t%s"
msgstr "帐户:%s"

# (pofilter) tabs: Different tabs
msgid "Active:               \t%s"
msgstr "活动:%s"

# (pofilter) tabs: Different tabs
msgid "Arch:                 \t%s"
msgstr "架构:%s"

# (pofilter) tabs: Different tabs
msgid "Contract:             \t%s"
msgstr "合同:%s"

# (pofilter) tabs: Different tabs
msgid "Description:          \t%s"
msgstr "描述:%s"

# (pofilter) tabs: Different tabs
msgid "Enabled:              \t%s"
msgstr "启用的:%s"

# (pofilter) tabs: Different tabs
msgid "Ends:                 \t%s"
msgstr "结束:%s"

# (pofilter) tabs: Different tabs
msgid "Multi-Entitlement:    \t%s"
msgstr "多个授权:%s"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "名称:%s"

# (pofilter) tabs: Different tabs
msgid "Pool Id:              \t%s"
msgstr "池子 Id:%s"

# (pofilter) tabs: Different tabs
msgid "Product ID:           \t%s"
msgstr "产品 ID:%s"

# (pofilter) tabs: Different tabs
msgid "Product Name:         \t%s"
msgstr "产品名称:%s"

# (pofilter) tabs: Different tabs
msgid "Provides:             \t%s"
msgstr "供应商:%s"

# (pofilter) tabs: Different tabs
msgid "Quantity Used:        \t%s"
msgstr "已使用的量:%s"

# (pofilter) tabs: Different tabs
msgid "Quantity:             \t%s"
msgstr "数量:%s"

# (pofilter) tabs: Different tabs
msgid "Repo Id:              \t%s"
msgstr "库 Id:%s"

# (pofilter) tabs: Different tabs
msgid "Repo Name:            \t%s"
msgstr "库名称:%s"

# (pofilter) tabs: Different tabs
msgid "Repo Url:             \t%s"
msgstr "库 Url:%s"

# (pofilter) tabs: Different tabs
msgid "Serial Number:        \t%s"
msgstr "序列号:%s"

# (pofilter) tabs: Different tabs
msgid "Service Level:        \t%s"
msgstr "服务等级:%s"

# (pofilter) tabs: Different tabs
msgid "Service Type:         \t%s"
msgstr "服务类型:%s"

# (pofilter) tabs: Different tabs
msgid "Starts:               \t%s"
msgstr "开始:%s"

# (pofilter) tabs: Different tabs
msgid "Status:               \t%s"
msgstr "状态:%s"

# (pofilter) tabs: Different tabs
msgid "Subscription Name:    \t%s"
msgstr "订阅名称:%s"

# (pofilter) tabs: Different tabs
msgid "Version:              \t%s"
msgstr "版本:%s"
[###########################################] 100%


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Wei Liu 2012-12-19 18:42:03 EST
"\t" has been added to those strings, and modified .po file is attached at 

https://engineering.redhat.com/rt/Ticket/Display.html?id=180952&results=d7c2aa7fbc39b7118eeab610a9fdaf1d
Comment 3 Adrian Likins 2013-01-04 13:39:41 EST
fixed upstream, should be in 1.1.19
Comment 5 John Sefler 2013-01-07 16:03:16 EST
Verfying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo > /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

VERIFIED: pofilter tabs tests are now passing
Comment 7 errata-xmlrpc 2013-02-21 04:05:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.