Bug 888900 - Horizon: login page is not localized
Horizon: login page is not localized
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-openstack-auth (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Matthias Runge
Yaniv Kaul
: i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 13:19 EST by Yaniv Kaul
Modified: 2013-07-03 22:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 04:35:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-12-19 13:19:27 EST
Description of problem:
If we do save the locale using a cookie, we should use it the next time the user access the login page.
Alternatively, we can use the browser's locale.
See also https://bugzilla.redhat.com/show_bug.cgi?id=838456


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Matthias Runge 2013-01-16 05:06:40 EST
Localization of login page is handled by browser configuration. Currently, python-django-openstack-auth has locale files for the following languages:
english, spanish, japanese and taiwanese. If we want more localizations, we should provide them upstream:

https://github.com/gabrielhurley/django_openstack_auth

/usr/lib/python2.7/site-packages/openstack_auth/locale/en/LC_MESSAGES/django.mo
/usr/lib/python2.7/site-packages/openstack_auth/locale/es/LC_MESSAGES/django.mo
/usr/lib/python2.7/site-packages/openstack_auth/locale/ja/LC_MESSAGES/django.mo
/usr/lib/python2.7/site-packages/openstack_auth/locale/zh_TW/LC_MESSAGES/django.mo
Comment 3 Matthias Runge 2013-01-16 05:15:44 EST
especially, we need the following strings to be localizesed:
#: backend.py:28
msgid "The authentication token issued by the Identity service has expired."
msgstr ""

#: backend.py:69
msgid "Invalid user name or password."
msgstr ""

#: backend.py:72
msgid "An error occurred authenticating. Please try again later."
msgstr ""

#: backend.py:84
msgid "Unable to retrieve authorized projects."
msgstr ""

#: backend.py:89
msgid "You are not authorized for any projects."
msgstr ""

#: backend.py:103
msgid "Unable to authenticate to any available projects."
msgstr ""

#: forms.py:20
msgid "Region"
msgstr ""

#: forms.py:21
msgid "User Name"
msgstr ""

#: forms.py:22
msgid "Password"
msgstr ""
Comment 4 Alvaro Lopez Ortega 2013-02-04 13:47:09 EST
Requested translation to the translation team today.
Comment 5 Julie Pichon 2013-02-05 04:35:52 EST
As mentioned by Matthias, the page localisation works and is set according to the browser locale. What we are lacking is additional translations (the only languages available are English, Spanish, Japanese, Chinese (Taiwan)).

To check it works, in e.g. Firefox: change the Display language to Spanish in the Preferences, then log out of Horizon. Reload the login page.

(Note: because of bug 907784, you may have to restart httpd to see the fully translated page.)

Note You need to log in before you can comment on or make changes to this bug.