Bug 888908 - SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'getattr' accesses on the directory /root/.kde.
SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'getattr' acce...
Status: CLOSED DUPLICATE of bug 888901
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:613bb44462ccbac47146e4a73bb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 13:35 EST by Jorrit
Modified: 2012-12-19 14:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 14:01:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-12-19 13:35 EST, Jorrit
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-12-19 13:36 EST, Jorrit
no flags Details

  None (edit)
Description Jorrit 2012-12-19 13:35:48 EST
Additional info:
libreport version: 2.0.18
kernel:         3.6.10-2.fc17.i686

description:
:SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'getattr' accesses on the directory /root/.kde.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that kcmdatetimehelper should be allowed getattr access on the .kde directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep kcmdatetimehelp /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:gnomeclock_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:config_home_t:s0
:Target Objects                /root/.kde [ dir ]
:Source                        kcmdatetimehelp
:Source Path                   /usr/libexec/kde4/kcmdatetimehelper
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           kde-workspace-4.9.4-2.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-161.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.10-2.fc17.i686 #1 SMP Tue Dec
:                              11 18:33:15 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-12-19 19:30:14 CET
:Last Seen                     2012-12-19 19:30:14 CET
:Local ID                      fefe6a6b-188e-4ba5-acd7-7b26c9822807
:
:Raw Audit Messages
:type=AVC msg=audit(1355941814.79:148): avc:  denied  { getattr } for  pid=5921 comm="kcmdatetimehelp" path="/root/.kde" dev="dm-1" ino=262164 scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=system_u:object_r:config_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1355941814.79:148): arch=i386 syscall=lstat64 success=yes exit=0 a0=bfd3e17b a1=bfd3e0a0 a2=4f050ff4 a3=978dd0e items=0 ppid=1 pid=5921 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=kcmdatetimehelp exe=/usr/libexec/kde4/kcmdatetimehelper subj=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 key=(null)
:
:Hash: kcmdatetimehelp,gnomeclock_t,config_home_t,dir,getattr
:
:audit2allow
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t config_home_t:dir getattr;
:
:audit2allow -R
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t config_home_t:dir getattr;
:
Comment 1 Jorrit 2012-12-19 13:35:56 EST
Created attachment 666281 [details]
File: type
Comment 2 Jorrit 2012-12-19 13:36:02 EST
Created attachment 666282 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-12-19 14:01:24 EST

*** This bug has been marked as a duplicate of bug 888901 ***

Note You need to log in before you can comment on or make changes to this bug.