Bug 888923 - [te] pofilter tabs test failed for several msgids
[te] pofilter tabs test failed for several msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 14:15 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 14:15:11 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter tabs TEST.  WHEN TRANSLATIING A msgid, THE "\t" CHARACTERS SHOULD NOT BE STRIPPED OUT.

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo > /usr/share/locale/te/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-18 02:20-0500\n"
"Last-Translator: kkrothap <kkrothap@fedoraproject.org>\n"
"Language-Team: Telugu <Fedora-trans-te@redhat.com>\n"
"Language: te\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) tabs: Different tabs
msgid "Arch:                 \t%s"
msgstr "ఆకృతి: %s"

# (pofilter) tabs: Different tabs
msgid "Description:          \t%s"
msgstr "వివరణ: %s"

# (pofilter) tabs: Different tabs
msgid "Enabled:              \t%s"
msgstr "చేతనమైన: %s"

# (pofilter) tabs: Different tabs
msgid "Multi-Entitlement:    \t%s"
msgstr "బహుళ-యెన్టైటిల్మెంట్: %s"

# (pofilter) tabs: Different tabs
msgid "Name:                 \t%s"
msgstr "పేరు: %s"

# (pofilter) tabs: Different tabs
msgid "Quantity:             \t%s"
msgstr "పరిమాణం: %s"

# (pofilter) tabs: Different tabs
msgid "Starts:               \t%s"
msgstr "ప్రారంభం: %s"

# (pofilter) tabs: Different tabs
msgid "Status:               \t%s"
msgstr "స్థితి: %s"

# (pofilter) tabs: Different tabs
msgid "Subscription Name:    \t%s"
msgstr "సబ్‌స్క్రిప్షన్ పేరు: %s"

# (pofilter) tabs: Different tabs
msgid "Version:              \t%s"
msgstr "వర్షన్: %s"
[###########################################] 100%


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Krishna Babu K 2012-12-20 03:07:13 EST
Hi,

I have update above mentioned msgstrs with '              \t' in 1.1.x branch in zanata.

Regards,
Krishna.
Comment 3 Adrian Likins 2013-01-04 13:39:09 EST
fixed upstread, should be in 1.1.19
Comment 5 John Sefler 2013-01-07 15:59:07 EST
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo > /usr/share/locale/te/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t tabs /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


VERIFIED: pofilter tabs test now passes
Comment 7 errata-xmlrpc 2013-02-21 04:05:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.