Bug 888946 - netinst, installer hangs
netinst, installer hangs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 16:06 EST by Aleksandar Kostadinov
Modified: 2013-04-15 09:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 09:14:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs from the problems with source repo (1.69 KB, application/x-compressed-tar)
2012-12-20 02:07 EST, Aleksandar Kostadinov
no flags Details
logs from time graphical installer could not start (1.52 KB, application/x-compressed-tar)
2012-12-20 03:20 EST, Aleksandar Kostadinov
no flags Details
source repo problem - boot.log (3.75 KB, text/x-log)
2013-02-12 04:34 EST, Aleksandar Kostadinov
no flags Details
source repo problem - wpa_supplicant.log (457 bytes, text/x-log)
2013-02-12 04:34 EST, Aleksandar Kostadinov
no flags Details
source repo problem - wtmp (384 bytes, application/octet-stream)
2013-02-12 04:35 EST, Aleksandar Kostadinov
no flags Details
GUI problem - boot.log (3.75 KB, text/x-log)
2013-02-12 04:36 EST, Aleksandar Kostadinov
no flags Details
GUI problem - wtmp (384 bytes, application/octet-stream)
2013-02-12 04:39 EST, Aleksandar Kostadinov
no flags Details

  None (edit)
Description Aleksandar Kostadinov 2012-12-19 16:06:24 EST
Since I didn't find these problems reported, I'll list them here.

1. from 3 attempts to install with netinst through wireless connection, only 1 detected install repo. I think that if network is not up fast enough, the "closest mirror" fails and one can't make it try again.
2. if closest mirror fails, one can try setting a http URL. If the url is wrong (e.g. aaa.fff.com or whatever, it doesn't seem to matter), intstaller hangs forever
3. so eventually I selected packages to  install, storage to auto-partitioning and clicked on continue. A screen is shown with an option to set root password and at the same time "preparing to install" on the bottom of the screen. Well I set root password (altough the thing complained it is simple). But intall process was just frozen on "preparing to install".

Let me know if I can tell anything more.
Comment 1 Brian Lane 2012-12-19 23:47:48 EST
Please switch to tty2 and copy all the /tmp/*log files someplace that you can attach them to this bug as individual plain/text files.
Comment 2 Aleksandar Kostadinov 2012-12-20 01:40:12 EST
sorry, logs are lost already. I think though there was some problem reclaiming space. This morning I started installer again and repeated all steps like I did last 3 attempts.

When I had to configure partitioning I noticed that partitions were modified from last time but not all original partitions were removed. I guess one can replicate by
1. create 3 primary partitions.
1.1. 2 with ext# and one as a lvm phy volume
2. create an extended partition with 2 sub-partitions, both lvm phy volumes
3. I think actually creating a LVM vg spanning over the 3 phy volumes can matter
4. try installing by selecting all partitions for removal
Comment 3 Aleksandar Kostadinov 2012-12-20 02:07:31 EST
Created attachment 666527 [details]
logs from the problems with source repo

I had to start installting for the fifth time (this time my mistake, power lost). Now I did setup wireless network immediately after network config window showed up. When connected I clicked continue. But source repo was not found. Attaching the logs in a tgz archive. If I hit any of the other bugs again, I'll attach logs for them as well.
Comment 4 Aleksandar Kostadinov 2012-12-20 03:20:26 EST
Created attachment 666535 [details]
logs from time graphical installer could not start

After so many installation attempts now I got a problem running the installation process. Attaching logs from that attempt. /logs_from_x_failure.tgz/
Comment 5 Aleksandar Kostadinov 2012-12-20 03:36:59 EST
One more thing I notice is that all parts of setup are very fragile. Now if I setup storage for deleting all partitions and automatic partitioning, and then if I click on storage config again, it behaves crazy. Clicking somewhere blocks every other click as if a background window is on focus. Clicking Esc allows you to click again but the only place that does not block is clicking on done. Where you click and see that storage has problems saving configuration. To recover I went to console, removed all partitions with fdisk and then after a minute or so, the sotrage config screen picked up that drive is empty and clicking ok resulted in success. I still can't click any other button than "done" to work sane (like if I wanted to do partitioning myself).

Storage config is one place that many users mess with, to allow for multi-os boot and such. Being so fragile will produce big pushback IMO if not fixed for GA.
Comment 6 Chris Lumens 2013-01-02 10:02:50 EST
As comment #1 explained, please attach logs as individual files, uncompressed.  Doing anything else prevents us from going through and searching bugzilla in the future.  Thanks.
Comment 7 Aleksandar Kostadinov 2013-01-02 10:27:42 EST
how do you want them named to avoid confusion? If you like, please see what files you actually need from the attached tarballs and I can upload them.
Comment 8 Aleksandar Kostadinov 2013-02-12 04:34:06 EST
Created attachment 696428 [details]
source repo problem - boot.log
Comment 9 Aleksandar Kostadinov 2013-02-12 04:34:57 EST
Created attachment 696429 [details]
source repo problem - wpa_supplicant.log
Comment 10 Aleksandar Kostadinov 2013-02-12 04:35:21 EST
Created attachment 696430 [details]
source repo problem - wtmp
Comment 11 Aleksandar Kostadinov 2013-02-12 04:36:37 EST
Created attachment 696432 [details]
GUI problem - boot.log
Comment 12 Aleksandar Kostadinov 2013-02-12 04:39:30 EST
Created attachment 696435 [details]
GUI problem - wtmp

Ok, here you go, attached plain text files. I hope you fix these bugs. Today I chatted with a guy on freenode with similar problem trying to install with a proxy. Perhaps if source selection fails once it cannot recover ever again? Fortunately he was able to workaround passing anaconda proxy parameter.

He didn't hit the GUI issue though.
Comment 13 Samantha N. Bueno 2013-02-19 14:46:25 EST
Are those all the logs that were in /tmp? There should've been a storage.log, anaconda.log, program.log, packaging.log, X.log, ifconfig.log
Comment 14 Samantha N. Bueno 2013-02-19 14:47:48 EST
Also, please mark your attachments as "plain text (text/plain)".
Comment 15 Aleksandar Kostadinov 2013-02-20 02:02:05 EST
I think these were from /var/log so it seems they are useless. But the problem is very easy to reproduce (the install source selection problem). So if you care to fix, then just try it out. I don't have any more time for this as well I don't have a test setup handy.

I am thinking based on comment 12 that the only thing necessary to reproduce is to delay network connectivity for whatever reason. It doesn't have to be wifi.

Regards
Comment 16 Chris Lumens 2013-04-15 09:14:38 EDT
I think this should be better in F19.

Note You need to log in before you can comment on or make changes to this bug.