Bug 888961 - Can't create glance image with non-ASCII name
Can't create glance image with non-ASCII name
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: snapshot5
: 2.1
Assigned To: Jakub Ruzicka
Attila Fazekas
: i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 17:07 EST by Russell Bryant
Modified: 2016-04-26 13:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.8.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 13:58:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 20807 None None None Never

  None (edit)
Description Russell Bryant 2012-12-19 17:07:56 EST
Description of problem:

Attempting to create an image in glance with a non-ASCII name fails.


Version-Release number of selected component (if applicable):

openstack-glance-2012.2.1-1.el6ost.noarch
python-glance-2012.2.1-1.el6ost.noarch
python-glanceclient-0.5.1-1.el6.noarch


Steps to Reproduce:

[root@rhel ~(keystone_username)]# glance image-create      --container-format  bare --disk-format qcow2      --name "El Niño" --copy-from http://berrange.fedorapeople.org/images/2012-11-15/f17-x86_64-openstack-sda.qcow2
'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
Comment 1 Russell Bryant 2012-12-19 17:12:01 EST
and probably the same bug exposed here ...

# glance image-update --name "El Niño" 5701fd2f-d1cb-4bcb-bb5d-fa9e9a4bbd51
'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
Comment 3 Alan Pevec 2012-12-21 12:44:45 EST
Looks like there's upstream work required to cleanup i18n issues across all openstack clients (see also novaclient bug 888483)
Comment 6 Yaniv Kaul 2013-02-20 03:20:21 EST
QE: worth adding a test case for Tempest for this.
Comment 8 Attila Fazekas 2013-03-17 14:12:26 EDT
ykaul: OK

Working.
Comment 10 errata-xmlrpc 2013-04-04 13:58:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0706.html

Note You need to log in before you can comment on or make changes to this bug.