Bug 889049 - vhostmd manpage problem
Summary: vhostmd manpage problem
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks: 1119573
TreeView+ depends on / blocked
 
Reported: 2012-12-20 06:15 UTC by Mohua Li
Modified: 2014-10-14 07:25 UTC (History)
8 users (show)

Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: wrong path to implicit config file was presented Consequence: confusing documentation Fix: change path to implicit config file Result: path is now correct
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 07:25:53 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vhostmd.8 -f default file (834 bytes, patch)
2014-06-13 08:32 UTC, Jan Chaloupka
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description Mohua Li 2012-12-20 06:15:35 UTC
Description of problem:

vhostmd manpage have something wrong,=20

       -f, --config <file>
              Specify a different configuration file. Normally /etc/vhostmd.xml
                                                      ^^^^^^^^^^^^^^^^^^^^^^^

should be "Normally /etc/vhostmd/vhostmd.conf"


Version-Release number of selected component (if applicable):
vhostmd-0.4-2.7.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 RHEL Product and Program Management 2013-06-07 14:31:30 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 9 Richard W.M. Jones 2013-08-19 13:53:53 UTC
Sorry I forgot about this one for RHEL 6.5.  Moving to RHEL 6.6.

Comment 11 Jan Chaloupka 2014-06-12 12:32:42 UTC
Still no pm_ack/rhel-6.6.0 acked. Is this planned to be fixed in this component or rather via MPO (oneliner only)?

Comment 12 Richard W.M. Jones 2014-06-12 15:01:52 UTC
It's an extremely simple change.  Unfortunately PM-acks are
not up to me!

Comment 13 Jan Chaloupka 2014-06-12 17:02:49 UTC
Looking at ACL, vhostmd is not on the list. I take it as a yes for MPO.

Comment 14 Richard W.M. Jones 2014-06-12 17:31:44 UTC
Sorry, I have no idea what MPO is.

Comment 15 Jan Chaloupka 2014-06-13 08:24:47 UTC
https://url.corp.redhat.com/mpo-rst

MPO = Man Pages Overrides

A process, where in order to change a man page, you don't have to update a component. MPO is a package with man pages and their patches. So instead of changing 10 components just for man page, you only add 10 patches to MPO package. It saves resources. Once the component gets green (there is a lot of man pages patches or at least one non man page change, it can be then updated in the component and patches from MPO are removed.

Comment 16 Jan Chaloupka 2014-06-13 08:32:03 UTC
Created attachment 908417 [details]
vhostmd.8 -f default file

Comment 17 Richard W.M. Jones 2014-06-23 08:48:45 UTC
No pm-ack so moving to 6.7.

Comment 23 errata-xmlrpc 2014-10-14 07:25:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.