Bug 889090 - Database password not printed out when adding db cartridge to applications
Database password not printed out when adding db cartridge to applications
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Regression
Depends On:
Blocks: 889095
  Show dependency treegraph
 
Reported: 2012-12-20 03:09 EST by Jianwei Hou
Modified: 2015-05-14 22:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 889095 (view as bug list)
Environment:
Last Closed: 2013-02-13 18:16:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-12-20 03:09:17 EST
Description of problem:
When adding db(mysql, mongo, postgresql) cartridge to an application, only connection url is displayed. The username, password and dbname are not printed out. 

Version-Release number of selected component (if applicable):
rhc-1.3.2
On devenv_2613

How reproducible:
Always

Steps to Reproduce:
1. Create an application
2. Add a db cartridge to the application
rhc cartridge add mysql-5.1 -a eap1
  
Actual results:
[hjw@rheltest devenv]$ rhc cartridge add mysql-5.1 -a eap1
Password: *
Adding 'mysql-5.1' to application 'eap1'
Success
mysql-5.1 (MySQL Database 5.1)
==============================
  Connection URL: mysql://127.1.3.1:3306/

[hjw@rheltest devenv]$ rhc cartridge show mysql-5.1 -a eap1 -px
mysql-5.1 (MySQL Database 5.1)
==============================
  Connection URL: mysql://127.1.3.1:3306/


Expected results:
Should print out username, password and dbname

Additional info:
Comment 1 Clayton Coleman 2013-01-02 15:56:30 EST
Introduced by my changeset.
Comment 2 Clayton Coleman 2013-01-02 16:06:49 EST
Fixed in https://github.com/openshift/rhc/pull/266

Once this is QA verified we will hotfix this for stage.
Comment 3 openshift-github-bot 2013-01-02 21:19:57 EST
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/e2135d129b4fe8c9d3ea284d5d53a7a43a0691c1
Bug 889090 - Password and other cart options should be displayed to the user on cart creation and on cart show.
Comment 4 Xiaoli Tian 2013-01-03 05:10:52 EST
(In reply to comment #2)
> Fixed in https://github.com/openshift/rhc/pull/266
> 
> Once this is QA verified we will hotfix this for stage.

Hmm, Guess this will not affect current released version rhc-1.2.7 since this is a regression bug since rhc-1.3.2.

It works for rhc-1.2.7.
Comment 5 Jianwei Hou 2013-01-03 21:31:37 EST
Verified on devenv_2632, rhc-1.3.2, the client is built from devenv_2632

Steps:
1. Create an application and embed mongo/mysql/postgresql cartridge to the app, the username, password and dbname should be displayed when cartridge is added successfully.


Added mongodb-2.2 to application perl1

MongoDB 2.2 database added.  Please make note of these credentials:

       Root User: admin
   Root Password: pCzhZ1S-FFWp
   Database Name: perl1

Connection URL: mongodb://$OPENSHIFT_MONGODB_DB_HOST:$OPENSHIFT_MONGODB_DB_PORT/

You can manage your new MongoDB by also embedding rockmongo-1.1
The rockmongo username and password will be the same as the MongoDB credentials above.


Added mysql-5.1 to application perl1

MySQL 5.1 database added.  Please make note of these credentials:

   Root User: admin
   Root Password: X2XcxcX2ZNCx
   Database Name: perl1

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin-3.4.
The phpmyadmin username and password will be the same as the MySQL credentials above.


Added postgresql-8.4 to application perl1

PostgreSQL 8.4 database added.  Please make note of these credentials:

   Root User: admin
   Root Password: TmKFsFVnQuZM
   Database Name: perl1

Connection URL: postgresql://$OPENSHIFT_POSTGRESQL_DB_HOST:$OPENSHIFT_POSTGRESQL_DB_PORT/

Note You need to log in before you can comment on or make changes to this bug.