Bug 889109 - missing dependencies for imsettings
missing dependencies for imsettings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 04:06 EST by Łukasz Posadowski
Modified: 2013-01-11 19:37 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 19:37:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Łukasz Posadowski 2012-12-20 04:06:22 EST
Description of problem:

yum update breaks, because of dependencies.

Version-Release number of selected component (if applicable):
imsettings-desktop-module(x86-32)-1.5.1.-1.fc18

How reproducible:
always

Steps to Reproduce:
1. yum update
2. meh
3.
  
Actual results:
--> Processing Dependency: imsettings-desktop-module(x86-32) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.i686
[...]
Error: Package: imsettings-1.5.1-1.fc18.i686 (updates-testing)
           Requires: imsettings-desktop-module(x86-32) = 1.5.1-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
#################################### 100%

Additional info:
I cleaned yum cache and checked:
# yum list *imsettings*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
imsettings.i686                                  1.5.0-2.fc18                            @updates-testing
imsettings-gnome.i686                            1.5.0-2.fc18                            @updates-testing
imsettings-libs.i686                             1.5.0-2.fc18                            @updates-testing
imsettings-qt.i686                               1.5.0-2.fc18                            @updates-testing
Available Packages
imsettings.i686                                  1.5.1-1.fc18                            updates-testing 
imsettings-devel.i686                            1.5.1-1.fc18                            updates-testing 
imsettings-gnome.i686                            1.5.1-1.fc18                            updates-testing 
imsettings-libs.i686                             1.5.1-1.fc18                            updates-testing 
imsettings-lxde.i686                             1.5.1-1.fc18                            updates-testing 
imsettings-mate.i686                             1.5.1-1.fc18                            updates-testing 
imsettings-qt.i686                               1.5.1-1.fc18                            updates-testing 
imsettings-xfce.i686                             1.5.1-1.fc18                            updates-testing 
imsettings-xim.i686                              1.5.1-1.fc18                            updates-testing 

Is imsettings-desktop-module(x86-32) really exists, or it's a bug in SPEC for imsettings? It says 
Requires: imsettings-desktop-module = %{version}-%{release}
and then
Provides: imsettings-desktop-module = %{version}-%{release}

Sounds like a chicken and egg. :)
Comment 1 Alex Hopcroft 2012-12-20 06:28:41 EST
I get the same problem on 64bit F18 when trying to install.

# yum install imsettings
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package imsettings.x86_64 0:1.5.1-1.fc18 will be installed
--> Processing Dependency: imsettings-libs(x86-64) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.x86_64
--> Processing Dependency: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.x86_64
--> Processing Dependency: libimsettings.so.5()(64bit) for package: imsettings-1.5.1-1.fc18.x86_64
--> Running transaction check
---> Package imsettings.x86_64 0:1.5.1-1.fc18 will be installed
--> Processing Dependency: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.x86_64
---> Package imsettings-libs.x86_64 0:1.5.1-1.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: imsettings-1.5.1-1.fc18.x86_64 (updates-testing)
           Requires: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
#
Comment 2 Petr Schindler 2012-12-20 07:57:01 EST
When you choose Gnome or KDE desktops in software selection in anaconda there is this dependency problem. So I propose this bug as blocker, but be aware, that this happens only when installing from netinst.iso.
Comment 3 Michael Verret 2012-12-20 13:11:23 EST
I have this same problem but did not install from netinst.iso.

I installed from Fedora-18-Beta-x86_64-Live-Desktop.iso and simply updated.

[michael@localhost ~]$ sudo yum update
[sudo] password for michael: 
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package imsettings.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings.x86_64 0:1.5.1-1.fc18 will be an update
--> Processing Dependency: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.x86_64
---> Package imsettings-gnome.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-gnome.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-libs.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-libs.x86_64 0:1.5.1-1.fc18 will be an update
--> Finished Dependency Resolution
Error: Package: imsettings-1.5.1-1.fc18.x86_64 (updates-testing)
           Requires: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[michael@localhost ~]$
Comment 4 Tim Flink 2012-12-20 19:45:18 EST
This is a problem with the imsettings-1.5.1-1.fc18 package which was in updates-testing. A fix has been built (1.5.1-2.fc18) and is being pushed to updates-testing now (should be done in an hour or two if it isn't done already).

Until the new update is pushed, you can work around this in one of two ways:
 1. disable updates-testing when installing
 2. remove the imsettings package from the packages to install
Comment 5 Akira TAGOH 2012-12-20 21:42:53 EST
I suspect this isn't worth proposing blocker because this was introduced since 1.5.0-1 which isn't yet pushed to stable and revoked by -2 now.
Comment 6 Łukasz Posadowski 2012-12-21 05:20:12 EST
imsettings in 32-bit repo is fixed. Thanks.
Comment 7 Joshua 2012-12-21 10:36:08 EST
This is what yum is doing with it on x86_64 virtualbox system updated from the first installable alpha to present. I don't even have Gnome desktop installed or Mate.

Resolving Dependencies
--> Running transaction check
---> Package imsettings.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings.x86_64 0:1.5.1-1.fc18 will be an update
--> Processing Dependency: imsettings-desktop-module(x86-64) = 1.5.1-1.fc18 for package: imsettings-1.5.1-1.fc18.x86_64
---> Package imsettings-gnome.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-gnome.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-libs.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-libs.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-qt.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-qt.x86_64 0:1.5.1-1.fc18 will be an update
--> Running transaction check
---> Package imsettings.x86_64 0:1.5.0-2.fc18 will be updated
--> Processing Dependency: imsettings-desktop-module = 1.5.0-2.fc18 for package: imsettings-1.5.0-2.fc18.x86_64
--> Processing Dependency: imsettings-libs = 1.5.0-2.fc18 for package: imsettings-1.5.0-2.fc18.x86_64
---> Package imsettings.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-gnome.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-qt.x86_64 0:1.5.1-1.fc18 will be an update
--> Running transaction check
---> Package imsettings-libs.i686 0:1.5.0-2.fc18 will be installed
--> Processing Dependency: librt.so.1 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libpthread.so.0 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libgobject-2.0.so.0 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libgmodule-2.0.so.0 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libglib-2.0.so.0 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libgio-2.0.so.0 for package: imsettings-libs-1.5.0-2.fc18.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: imsettings-libs-1.5.0-2.fc18.i686
---> Package imsettings-libs.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-libs.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-mate.x86_64 0:1.5.0-2.fc18 will be installed
--> Processing Dependency: mate-settings-daemon >= 1.5.0 for package: imsettings-mate-1.5.0-2.fc18.x86_64
--> Processing Dependency: mate-session-manager for package: imsettings-mate-1.5.0-2.fc18.x86_64
--> Running transaction check
---> Package glib2.i686 0:2.34.2-1.fc18 will be installed
--> Processing Dependency: libz.so.1(ZLIB_1.2.2) for package: glib2-2.34.2-1.fc18.i686
--> Processing Dependency: libz.so.1 for package: glib2-2.34.2-1.fc18.i686
--> Processing Dependency: libselinux.so.1 for package: glib2-2.34.2-1.fc18.i686
--> Processing Dependency: libffi.so.5 for package: glib2-2.34.2-1.fc18.i686
--> Processing Dependency: libfam.so.0 for package: glib2-2.34.2-1.fc18.i686
---> Package glibc.i686 0:2.16-28.fc18 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.16-28.fc18.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.16-28.fc18.i686
---> Package mate-session-manager.x86_64 0:1.5.0-1.fc18 will be installed
---> Package mate-settings-daemon.x86_64 0:1.5.4-1.fc18 will be installed
--> Processing Dependency: mate-icon-theme for package: mate-settings-daemon-1.5.4-1.fc18.x86_64
--> Processing Dependency: libmatenotify.so.1()(64bit) for package: mate-settings-daemon-1.5.4-1.fc18.x86_64
--> Processing Dependency: libmatekbdui.so.4()(64bit) for package: mate-settings-daemon-1.5.4-1.fc18.x86_64
--> Processing Dependency: libmatekbd.so.4()(64bit) for package: mate-settings-daemon-1.5.4-1.fc18.x86_64
--> Processing Dependency: libmate-desktop-2.so.17()(64bit) for package: mate-settings-daemon-1.5.4-1.fc18.x86_64
--> Running transaction check
---> Package gamin.i686 0:0.1.10-13.fc18 will be installed
---> Package libffi.i686 0:3.0.10-3.fc18 will be installed
---> Package libmatekbd.x86_64 0:1.5.0-2.fc18 will be installed
---> Package libmatenotify.x86_64 0:1.5.0-1.fc18 will be installed
---> Package libselinux.i686 0:2.1.12-7.fc18 will be installed
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.1.12-7.fc18.i686
---> Package mate-desktop-libs.x86_64 0:1.5.5-1.fc18 will be installed
--> Processing Dependency: mate-desktop = 1.5.5-1.fc18 for package: mate-desktop-libs-1.5.5-1.fc18.x86_64
---> Package mate-icon-theme.noarch 0:1.5.0-1.fc18 will be installed
---> Package nss-softokn-freebl.i686 0:3.14-5.fc18 will be installed
---> Package zlib.i686 0:1.2.7-9.fc18 will be installed
--> Running transaction check
---> Package mate-desktop.x86_64 0:1.5.5-1.fc18 will be installed
--> Processing Dependency: xdg-user-dirs-gtk for package: mate-desktop-1.5.5-1.fc18.x86_64
--> Processing Dependency: libunique-1.0.so.0()(64bit) for package: mate-desktop-1.5.5-1.fc18.x86_64
---> Package pcre.i686 0:8.31-3.fc18 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.31-3.fc18.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.31-3.fc18.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.31-3.fc18.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.31-3.fc18.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.31-3.fc18.i686
--> Processing Dependency: libgcc_s.so.1 for package: pcre-8.31-3.fc18.i686
--> Running transaction check
---> Package libgcc.i686 0:4.7.2-8.fc18 will be installed
---> Package libstdc++.i686 0:4.7.2-8.fc18 will be installed
---> Package unique.x86_64 0:1.1.6-8.fc18 will be installed
---> Package xdg-user-dirs-gtk.x86_64 0:0.9-2.fc18 will be installed
--> Running transaction check
---> Package gamin.i686 0:0.1.10-13.fc18 will be installed
---> Package glib2.i686 0:2.34.2-1.fc18 will be installed
---> Package glibc.i686 0:2.16-28.fc18 will be installed
---> Package imsettings-libs.i686 0:1.5.0-2.fc18 will be installed
---> Package imsettings-libs.x86_64 0:1.5.0-2.fc18 will be updated
---> Package imsettings-libs.x86_64 0:1.5.1-1.fc18 will be an update
---> Package imsettings-mate.x86_64 0:1.5.0-2.fc18 will be installed
---> Package libffi.i686 0:3.0.10-3.fc18 will be installed
---> Package libgcc.i686 0:4.7.2-8.fc18 will be installed
---> Package libmatekbd.x86_64 0:1.5.0-2.fc18 will be installed
---> Package libmatenotify.x86_64 0:1.5.0-1.fc18 will be installed
---> Package libselinux.i686 0:2.1.12-7.fc18 will be installed
---> Package libstdc++.i686 0:4.7.2-8.fc18 will be installed
---> Package mate-desktop.x86_64 0:1.5.5-1.fc18 will be installed
---> Package mate-desktop-libs.x86_64 0:1.5.5-1.fc18 will be installed
---> Package mate-icon-theme.noarch 0:1.5.0-1.fc18 will be installed
---> Package mate-session-manager.x86_64 0:1.5.0-1.fc18 will be installed
---> Package mate-settings-daemon.x86_64 0:1.5.4-1.fc18 will be installed
---> Package nss-softokn-freebl.i686 0:3.14-5.fc18 will be installed
---> Package pcre.i686 0:8.31-3.fc18 will be installed
---> Package unique.x86_64 0:1.1.6-8.fc18 will be installed
---> Package xdg-user-dirs-gtk.x86_64 0:0.9-2.fc18 will be installed
---> Package zlib.i686 0:1.2.7-9.fc18 will be installed
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    imsettings-1.5.1-1.fc18.x86_64 from updates-testing
    imsettings-gnome-1.5.1-1.fc18.x86_64 from updates-testing
    imsettings-qt-1.5.1-1.fc18.x86_64 from updates-testing
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for imsettings-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of imsettings-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude imsettings-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of imsettings-libs installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of imsettings-libs installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: imsettings-libs-1.5.1-1.fc18.x86_64 != imsettings-libs-1.5.0-2.fc18.i686
Comment 8 Adam Williamson 2012-12-21 15:20:48 EST
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Rejected as a blocker, as the issue only existed in updates-testing, never went stable, and doesn't really affect the compose package set anyway. The update has since been amended to fix this problem.
Comment 9 Fedora Update System 2013-01-11 19:37:14 EST
imsettings-1.5.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.