Bug 889124 - trident module failed to load - undefined symbol: TRIDENT_Sync
Summary: trident module failed to load - undefined symbol: TRIDENT_Sync
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-trident
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 835259 895654
TreeView+ depends on / blocked
 
Reported: 2012-12-20 09:55 UTC by Tomas Pelka
Modified: 2013-02-21 08:06 UTC (History)
1 user (show)

Fixed In Version: xorg-x11-drv-trident-1.3.6-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:06:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
example config file (1.31 KB, text/plain)
2012-12-20 09:55 UTC, Tomas Pelka
no flags Details
xorg.log (4.97 KB, text/plain)
2012-12-20 09:56 UTC, Tomas Pelka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:0301 0 normal SHIPPED_LIVE xorg-x11 drivers enhancement update 2013-02-20 20:55:08 UTC

Description Tomas Pelka 2012-12-20 09:55:37 UTC
Created attachment 666572 [details]
example config file

Description of problem:
[ 50685.525] (II) LoadModule: "trident"
[ 50685.526] (II) Loading /usr/lib/xorg/modules/drivers/trident_drv.so
[ 50685.526] (EE) Failed to load /usr/lib/xorg/modules/drivers/trident_drv.so: /usr/lib/xorg/modules/drivers/trident_drv.so: undefined symbol: TRIDENT_Sync
[ 50685.526] (II) UnloadModule: "trident"
[ 50685.526] (II) Unloading trident
[ 50685.526] (EE) Failed to load module "trident" (loader failed, 7)
[ 50685.526] (EE) No drivers available.


Version-Release number of selected component (if applicable):
kernel-2.6.32-348.el6
xorg-x11-drv-trident-1.3.6-2.el6
xorg-x11-server-Xorg-1.13.0-9.el6

How reproducible:
100%

Steps to Reproduce:
1. try to load trident module 
2.
3.
  
Actual results:
[ 50685.526] (EE) Failed to load /usr/lib/xorg/modules/drivers/trident_drv.so: /usr/lib/xorg/modules/drivers/trident_drv.so: undefined symbol: TRIDENT_Sync
[ 50685.526] (II) UnloadModule: "trident"
[ 50685.526] (II) Unloading trident
[ 50685.526] (EE) Failed to load module "trident" (loader failed, 7)

Expected results:
Should load even if real device is not in the box.

Additional info:

Comment 1 Tomas Pelka 2012-12-20 09:56:20 UTC
Created attachment 666573 [details]
xorg.log

Comment 3 Adam Jackson 2012-12-20 15:39:44 UTC
Trivial, dev ack.

Comment 4 RHEL Program Management 2012-12-20 15:42:34 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 6 Adam Jackson 2013-01-04 17:29:43 UTC
  5238855 buildArch (xorg-x11-drv-trident-1.3.6-4.el6.src.rpm, x86_64): closed
5238851 build (rhel-6.4-xorg-rebase, /rpms/xorg-x11-drv-trident:481f63560900af5b19ff8254e433a1bddce07a9e) completed successfully

MODIFIED

Comment 10 errata-xmlrpc 2013-02-21 08:06:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0301.html


Note You need to log in before you can comment on or make changes to this bug.