Bug 889169 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.3.2.fc17: exit: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.9-2.3.3.2.fc17: exit: Process /usr/lib/jvm/ja...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:41234a85fd6f4c58fcffd7b8d58...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 07:24 EST by costashu
Modified: 2013-02-19 05:45 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 05:45:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (4.18 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: environ (1.74 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: backtrace (58.22 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: smolt_data (3.12 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: executable (59 bytes, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: maps (46.66 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: dso_list (8.50 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: proc_pid_status (912 bytes, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: var_log_messages (1.39 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: open_fds (1.06 KB, text/plain)
2012-12-20 07:24 EST, costashu
no flags Details
File: build_ids (2.68 KB, text/plain)
2012-12-20 07:25 EST, costashu
no flags Details

  None (edit)
Description costashu 2012-12-20 07:24:28 EST
Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.9-2.3.3.2.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.5 -XX:MaxPermSize=256m -Xms40m -Xmx512m -jar /home/costa/eclipse3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /home/costa/eclipse3/eclipse -name Eclipse --launcher.library /home/costa/eclipse3//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so -startup /home/costa/eclipse3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar --launcher.overrideVmargs -exitdata 3e88032 -product org.eclipse.epp.package.modeling.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.5 -XX:MaxPermSize=256m -Xms40m -Xmx512m -jar /home/costa/eclipse3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
crash_function: exit
kernel:         3.6.10-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #16 exit at exit.c:100
: #17 vm_direct_exit at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/java.cpp:570
: #18 VM_Operation::evaluate at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vm_operations.cpp:70
: #19 VMThread::evaluate_operation at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vmThread.cpp:379
: #20 VMThread::loop at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vmThread.cpp:491
: #21 VMThread::run at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vmThread.cpp:284
: #22 java_start at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
Comment 1 costashu 2012-12-20 07:24:33 EST
Created attachment 666629 [details]
File: core_backtrace
Comment 2 costashu 2012-12-20 07:24:35 EST
Created attachment 666630 [details]
File: environ
Comment 3 costashu 2012-12-20 07:24:39 EST
Created attachment 666631 [details]
File: backtrace
Comment 4 costashu 2012-12-20 07:24:41 EST
Created attachment 666632 [details]
File: limits
Comment 5 costashu 2012-12-20 07:24:43 EST
Created attachment 666633 [details]
File: cgroup
Comment 6 costashu 2012-12-20 07:24:45 EST
Created attachment 666634 [details]
File: smolt_data
Comment 7 costashu 2012-12-20 07:24:47 EST
Created attachment 666635 [details]
File: executable
Comment 8 costashu 2012-12-20 07:24:49 EST
Created attachment 666636 [details]
File: maps
Comment 9 costashu 2012-12-20 07:24:51 EST
Created attachment 666637 [details]
File: dso_list
Comment 10 costashu 2012-12-20 07:24:54 EST
Created attachment 666638 [details]
File: proc_pid_status
Comment 11 costashu 2012-12-20 07:24:56 EST
Created attachment 666639 [details]
File: var_log_messages
Comment 12 costashu 2012-12-20 07:24:58 EST
Created attachment 666640 [details]
File: open_fds
Comment 13 costashu 2012-12-20 07:25:00 EST
Created attachment 666641 [details]
File: build_ids
Comment 14 Deepak Bhole 2013-01-10 15:44:02 EST
The problem is arising from /home/costa/eclipse3/features/com.UniqueSoft.VRSClient_4.5.0.v18_2012121701/64/libvalidator.so which looks like a 3rd party app, and it is unsupported.

Still, moving component to Eclipse so that they are in the loop and can close as needed.
Comment 15 Alexander Kurtakov 2013-02-19 05:45:51 EST
Closing. Please reopen if the bug happens with VRSClient uninstalled. There is zero we can do about crashes in native code in third party plugins.

Note You need to log in before you can comment on or make changes to this bug.