Bug 889201 - tcl-8.6.0 is available
Summary: tcl-8.6.0 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 847560 1010197 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-20 13:45 UTC by Upstream Release Monitoring
Modified: 2014-07-11 14:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-10 15:18:55 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2012-12-20 13:45:51 UTC
Latest upstream release: 8.6.0
Current version in Fedora Rawhide: 8.5.13
URL: http://sourceforge.net/api/file/index/project-name/tcl/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Account closed by the user 2013-05-30 12:21:25 UTC
ping ! will it be ready for f20 ?

Comment 2 Jaroslav Škarvada 2013-05-30 12:29:40 UTC
(In reply to Xose Vazquez Perez from comment #1)
> ping ! will it be ready for f20 ?

Could be real, I need to investigate.

Comment 3 George Petasis 2013-08-09 06:44:08 UTC
It would be nice if it could make it for fedora 20...

Comment 4 Jaroslav Škarvada 2013-08-15 15:02:28 UTC
*** Bug 847560 has been marked as a duplicate of this bug. ***

Comment 5 Jaroslav Škarvada 2013-08-15 15:24:53 UTC
At least it now builds OK in rawhide, private branches:
http://pkgs.fedoraproject.org/cgit/tcl.git/?h=private-master-8.6
http://pkgs.fedoraproject.org/cgit/tk.git/?h=private-master-8.6

Checking rebuild of all other packages that have tcl/tk as direct dep (cca. 120 packages).

Comment 6 Jaroslav Škarvada 2013-08-16 08:02:18 UTC
More than 40 % of builds failed. Sorry, it's probably unreal to resolve this all for f20, change freeze is approaching. I will propose this as a Change for f21.

Comment 7 Mike Manilone 2013-08-16 14:35:46 UTC
(In reply to Jaroslav Škarvada from comment #6)
> More than 40 % of builds failed. Sorry, it's probably unreal to resolve this
> all for f20, change freeze is approaching. I will propose this as a Change
> for f21.

Would it be okay to build it for Fedora 19? I mean I build it by myself.

Comment 8 Jaroslav Škarvada 2013-08-16 15:24:16 UTC
(In reply to Mike Manilone from comment #7)
> (In reply to Jaroslav Škarvada from comment #6)
> > More than 40 % of builds failed. Sorry, it's probably unreal to resolve this
> > all for f20, change freeze is approaching. I will propose this as a Change
> > for f21.
> 
> Would it be okay to build it for Fedora 19? I mean I build it by myself.

I tried only on rawhide, but I think it should build on F19 as well. But this is unsupported, I do not plan to deliver such update to the F19 (due to many packages that needs rebuild).

Comment 9 Christopher Meng 2013-08-17 01:46:42 UTC
Yes, that's the policy of Fedora. 

Due to so many FTBFS problem, may be we should start working for f21.

Comment 10 George Petasis 2013-08-17 09:51:18 UTC
From what I understand, tck/tk 8.6 builds, but many other packages fail. Is there a way I can see these failing packages and try to help?

Comment 11 Jaroslav Škarvada 2013-08-19 08:15:41 UTC
(In reply to George Petasis from comment #10)
> From what I understand, tck/tk 8.6 builds, but many other packages fail. Is
> there a way I can see these failing packages and try to help?

Thanks. Yes, the SPECs from the private branches above built now both OK in the rawhide. I tried to rebuilt depending packages locally in the mock. From the logs it seems many failures are the same problems, it shouldn't be probably hard to fix. The list of packages that failed:
http://www.fpaste.org/33031/

If you are interested I can upload the build logs as well. I will start creating patches later this week. I plan to create/request rebuild tag after the f20 will be branched.

Comment 12 Jaroslav Škarvada 2013-08-19 11:37:17 UTC
It seems that many of the failures can be workarounded by rebuilding the failing packages with the -DUSE_INTERP_ERRORLINE and -DUSE_INTERP_RESULT CFLAGS. Several other packages needs fixing their SPECs and Makefiles as they link directly with the libtcl/tk8.5. I will go through it step-by-step.

Comment 13 George Petasis 2013-08-19 17:15:06 UTC
I see. Both are easy to fix, and they occurred because now the interpreter pointer does not actually allow access to any of its structure fields.
We have to substitute reads of interp->result with (char *) Tcl_GetStringResult(interp), and writes to interp->result = <value> with Tcl_SetResult(interp, <value>, TCL_VOLATILE).

Similarly, reads of interp->errorLine should use Tcl_GetErrorLine(interp),
and writes interp->errorLine = <value> should use Tcl_SetErrorLine(interp, <value>).

For extensions (that will be loaded into a tcl interpreter) that link directly to the tcl library, the definition -DUSE_TCL_STUBS must be used (and -DUSE_TK_STUBS) for extensions that use also Tk.
Tcl extensions must call Tcl_InitStubs(interp, TCL_VERSION, 0) in their *_Init() functions.

I am trying to install rawhide into a WMWare 9 Workstation, but without much luck for the time being...

Comment 14 Jaroslav Škarvada 2013-09-24 09:58:38 UTC
Opened rel-eng ticket for the tag:
http://fedorahosted.org/rel-eng/ticket/5779

Comment 15 Jaroslav Škarvada 2013-11-04 17:11:11 UTC
There is now target=f21-tcl.(In reply to Jaroslav Škarvada from comment #14)
> Opened rel-eng ticket for the tag:
> http://fedorahosted.org/rel-eng/ticket/5779

There is now target=f21-tcl.

I am going to start the work later this week.

Comment 16 Christopher Meng 2013-11-05 11:38:33 UTC
(In reply to Jaroslav Škarvada from comment #15)
> There is now target=f21-tcl.(In reply to Jaroslav Škarvada from comment #14)
> > Opened rel-eng ticket for the tag:
> > http://fedorahosted.org/rel-eng/ticket/5779
> 
> There is now target=f21-tcl.
> 
> I am going to start the work later this week.

A SELF CONTAINED change for Fedora 21? Will you create a new page of this?

Comment 17 Jaroslav Škarvada 2013-11-13 15:46:58 UTC
(In reply to Christopher Meng from comment #16)
> (In reply to Jaroslav Škarvada from comment #15)
> > There is now target=f21-tcl.(In reply to Jaroslav Škarvada from comment #14)
> > > Opened rel-eng ticket for the tag:
> > > http://fedorahosted.org/rel-eng/ticket/5779
> > 
> > There is now target=f21-tcl.
> > 
> > I am going to start the work later this week.
> 
> A SELF CONTAINED change for Fedora 21? Will you create a new page of this?

I am not sure about it now, but we could create one.

Comment 18 Christopher Meng 2014-02-22 13:08:36 UTC
F21 has started to scrape changes, any updates on this one?

Comment 19 Jaroslav Škarvada 2014-04-08 13:36:49 UTC
(In reply to Christopher Meng from comment #18)
> F21 has started to scrape changes, any updates on this one?

https://fedoraproject.org/wiki/Changes/f21tcl86

Proposed.

Comment 20 Account closed by the user 2014-05-01 09:46:49 UTC
(In reply to Upstream Release Monitoring from comment #0)

> Latest upstream release: 8.6.0

DONE:
http://koji.fedoraproject.org/koji/buildinfo?buildID=514354
http://koji.fedoraproject.org/koji/buildinfo?buildID=514444

-thanks-

Comment 21 Jaroslav Škarvada 2014-07-11 14:27:27 UTC
*** Bug 1010197 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.