Bug 889202 - [rfe] [repos] add support for skip_if_unavailable in repository config
Summary: [rfe] [repos] add support for skip_if_unavailable in repository config
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 18
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 920271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-20 13:46 UTC by Jan Vcelak
Modified: 2014-09-30 23:40 UTC (History)
4 users (show)

Fixed In Version: dnf-0.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-02 14:29:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Vcelak 2012-12-20 13:46:20 UTC
Description of problem:

Yum supports skip_if_unavailable option in repositories configuration. If the repository cannot be contacted for any reason, it causes Yum not to exit with an error but to continue running.


Version-Release number of selected component (if applicable):
dnf-0.2.17-1.git6a055e6.fc18.noarch

How reproducible:
always


Steps to Reproduce:
1. set up some nonexisting repository with skip_if_unavailable=1
2. dnf/yum distro-sync
3.
  
Actual results:

# dnf distro-sync
Setting up Distribution Synchronization Process
Resolving Dependencies
--> Starting dependency resolution
Could not retrieve mirrorlist http://example error was
14: curl#7 - "Couldn't connect"
Error: Cannot find a valid baseurl for repo: example
(exit)

# yum distro-sync
Loaded plugins: auto-update-debuginfo, keys, presto, remove-with-leaves, security, show-leaves
Could not retrieve mirrorlist http://example error was
14: curl#7 - "Couldn't connect"
...
No Packages marked for Distribution Synchronization


Expected results:


Additional info:

Comment 1 Ales Kozumplik 2013-01-21 14:42:44 UTC
Some more information about this feature: this works and is a part of Yum. It got unintentionally dropped in the current DNF but should be possible to re-add.

Comment 2 Ales Kozumplik 2013-01-30 12:15:28 UTC
This is waiting for librepo[1] integration.

[1] https://github.com/tojaj/librepo

Comment 4 Ales Kozumplik 2013-04-02 14:29:09 UTC
Commit ab1da2a enables this configuration item again in DNF, will be included in version 0.3.2.

Comment 5 Ales Kozumplik 2013-04-02 15:17:06 UTC
*** Bug 920271 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.