Bug 889259 - /usr/bin/xauth: timeout in locking authority file
Summary: /usr/bin/xauth: timeout in locking authority file
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-xauth
Version: 6.4
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-20 16:07 UTC by Jiri Koten
Modified: 2015-11-16 10:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-16 10:47:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Koten 2012-12-20 16:07:31 UTC
Description of problem:
I have user test whose home dir is located in /home/test6, i.e. user name and home dir name are different.

xauth fails to create authority file when I try to use ssh X forwarding. 
 

Version-Release number of selected component (if applicable):
xorg-x11-xauth-1.0.2-7.1.el6

How reproducible:
100%

Steps to Reproduce:
1. useradd -d /home/test6 test
2. ssh -X test@localhost
  
Actual results:
/usr/bin/xauth:  timeout in locking authority file /home/test6/.Xauthority

Expected results:
xauth successfully creates authorization record, X forwarding is working

Comment 2 RHEL Program Management 2013-10-14 00:07:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 4 Hans de Goede 2015-11-16 10:47:05 UTC
I cannot reproduce this with 6.7, so I'm going to close this bug. Feel free to re-open it if you are still seeing this issue on RHEL-6.7 or newer.


Note You need to log in before you can comment on or make changes to this bug.