Bug 889366 - "Don't install the latest available software updates. Install the default versions provided by the install source above." checkbox does nothing, media installs don't default to installing updates
Summary: "Don't install the latest available software updates. Install the default ver...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH
Depends On:
Blocks: F18-accepted, F18FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-12-20 23:10 UTC by Adam Williamson
Modified: 2013-01-02 21:50 UTC (History)
8 users (show)

Fixed In Version: anaconda-18.37.7-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-02 21:50:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2012-12-20 23:10:22 UTC
There is a checkbox labelled "Don't install the latest available software updates. Install the default versions provided by the install source above." on the Installation Source spoke of anaconda.

So far as I can tell it does absolutely nothing.

A media-based (DVD) install just installs the packages from the DVD, it does not default to also pulling in packages from the remote repos, as the checkbox kind of suggests it should. Checking the checkbox appears to make no difference in behaviour at all.

The checkbox is even present when you're doing a network install. I've no idea what it would be expected to do in that case - disable the 'updates' repo? Seems an odd option, but whatever.

It may be late to actually _fix_ this for F18, but could we ditch the checkbox at least, since it does nothing and would just confuse people?

Comment 1 Adam Williamson 2012-12-20 23:12:16 UTC
Nominating as NTH - the presence of the checkbox is a bit confusing, it implies things about anaconda's behaviour which are not at present true, and it does nothing.

Comment 2 Andre Robatino 2012-12-20 23:19:07 UTC
Personally I think the ideal thing to do would be to have such a checkbox, but default to NOT downloading updates (since most people who aren't concerned about the extra bandwidth of downloading full updates as opposed to using presto would probably use the netinst instead). Many people using the DVD have low bandwidth, order the DVD instead of downloading, and want to keep their updates as small as possible.

Comment 3 Andre Robatino 2012-12-20 23:20:29 UTC
Of course, if there isn't time to fix the checkbox, I agree with Adam that it should be scrapped, at least for now.

Comment 4 Andre Robatino 2012-12-20 23:42:40 UTC
Should add that it seems inconsistent to me to 1) install yum-presto by default in order to save bandwidth on updates, but 2) have the DVD installer bypass it by downloading full updates directly. I think the Fedora community should decide how big of an issue bandwidth is for its users (and the mirrors), and then set the default in both places consistently.

Comment 5 Kevin Fenzi 2012-12-21 17:52:08 UTC
+1 NTH.

Comment 6 d. johnson 2012-12-21 18:31:57 UTC
The install media should install what is on the media by default, with a selector box that says something like "also download updates".  Positive verbiage instead of negative (when told "dont do this" it is a negative connotation.)

The box can be auto-selected or not, does not make much difference.

If the box is present, it MUST do something different checked vs unchecked.

Comment 7 Andre Robatino 2012-12-21 18:43:42 UTC
+1 NTH

Comment 8 Adam Williamson 2012-12-21 21:42:14 UTC
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Accepted as NTH - displaying features that do nothing is confusing and unfriendly.

Comment 9 Fedora Update System 2012-12-21 23:33:01 UTC
dracut-024-17.git20121220.fc18, anaconda-18.37.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.7-1.fc18

Comment 10 Andre Robatino 2012-12-22 01:51:12 UTC
Confirmed that the updates checkbox is gone in smoke11 (both DVD and netinst).

smoke11 (anaconda-18.37.7-1, fedora-release-1): http://dl.fedoraproject.org/pub/alt/qa/20121221_f18-smoke11/

Comment 11 Fedora Update System 2013-01-02 21:50:43 UTC
dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.