Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 889389 - anaconda rejects storage configuration even if one sets to 'delete' a 'whole-disk' part of zfs zpool (affects automatic partitioning)
Summary: anaconda rejects storage configuration even if one sets to 'delete' a 'whole-...
Keywords:
Status: CLOSED DUPLICATE of bug 889388
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-21 02:51 UTC by Reartes Guillermo
Modified: 2012-12-21 17:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-21 17:05:29 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (no gpt) (7.06 KB, text/x-log)
2012-12-21 02:51 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2012-12-21 02:51:21 UTC
Created attachment 667065 [details]
anaconda.log (no gpt)

Description of problem:

currently anaconda cannot use automatic partitioning to utilize a disk that has is part of a zpool (efi labeled) even if the user sets the 'whole disk' to 'delete'. The storage configuration is rejected in the main hub.

Version-Release number of selected component (if applicable):
smoke9 (18.37.5)

How reproducible:
always

Steps to Reproduce:

0. Boot (with or without gpt boot parameter) anaconda smoke9 (18.37.5)

1. Enter STORAGE: INSTALLATION DESTINATION and select a ZFS zpool member disk (example: sdb)

2. In INSTALLATION OPTIONS, select AUTOMATIC PARTITIONING (leave the default scheme: lvm)
 
3. Select the action 'Delete' for the 'whole disk' and do a 'Reclaim Space'

4. In the main hub, STORAGE: INSTALLATION DESTINATION rejects the storage configuration

  
Actual results:
cannot do automatic partitioning (but no crash)

Expected results:
be able to 'delete' the 'whole-dis' (for which a new partition table MUST be created, since the current efi label is inadecuate).(and honor the default disklabel).

Additional info:

Comment 1 Brian Lane 2012-12-21 17:05:29 UTC

*** This bug has been marked as a duplicate of bug 889388 ***


Note You need to log in before you can comment on or make changes to this bug.