Bug 889410 - [virtio-win][netkvm] Network fail to access remote computer after enable netkvm driver parameter "TestOnly.UseSwTxChecksum".
Summary: [virtio-win][netkvm] Network fail to access remote computer after enable netk...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-21 05:29 UTC by dawu
Modified: 2013-11-22 00:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: TCP offload code was optimised. The test only mode of offload emulation in drivers wasn't not changed and therefore was not functional. Consequence: If user triggered SW offload test mode, the network became unavailable. Fix: Remove the SW emulation of TCP/IP offload. Result: Guest will aways try to use host offload capabilities.
Clone Of:
Environment:
Last Closed: 2013-11-22 00:00:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description dawu 2012-12-21 05:29:43 UTC
Description of problem:
Guest network fails to access remote computer after enable netkvm driver parameter "TestOnly.UseSwTxChecksum". But can ping remote computer from guest.

Version-Release number of selected component (if applicable):
kernel-2.6.32-348.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.344.el6.x86_64
virtio-win-prewhql-49

How reproducible:
100%

Steps to Reproduce:
1.Start guest with CLI:
  /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=2k8-R2-network.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=00:10:16:23:78:01,bus=pci.0,addr=0x4,id=net0  -uuid 93467808-bc3f-40ec-82be-0d8f50b5b862 -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win2k8-R2-network -spice disable-ticketing,port=5931 -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0

2.Enable netkvm parameter "TestOnly.UseSwTxChecksum" from Device Manager --> Network adapters--> right-click PropertiesRedhat VirIO Ethernet Adapter---> Properties---> Advanced
3.Click Start --> Run and try to access shared folder on the remote computer such as \\10.66.73.47
  
Actual results:
Network fail to access remote computer with error dialogue prompt "Windows can not access \\10.66.73.47".When change to disable, it works well again.

Expected results:
Network should work well after enable netkvm driver parameter "TestOnly.UseSwTxChecksum".

Additional info:
Tried on rhel6.3 with driver virtio-win-1.5.3,network can work without any error.

Comment 3 Yan Vugenfirer 2012-12-23 08:37:06 UTC
Hi,

This is very minor bug.  "TestOnly" parameters shouldn't be changed for in production environment and are intended for debugging only (I am thinking to remove them at all so they won't confuse anyone). TestOnly.UseSwTxChecksum - should emulate all offloads in the driver instead of using host capabilities. This is definitely test only mode as it will diminish the performance, it was used a really long time ago to pass WHQL when the offload in host\QEMU was unstable. I don't think now it is even make sense to invest in keeping this code alive.


Best regards,
Yan.

Comment 4 Ronen Hod 2012-12-23 14:04:33 UTC
Probably this code needs to be removed. Anyhow, postponed to 6.5.

Comment 7 lijin 2013-04-17 02:22:47 UTC
test on version virtio-win-prewhql-49 also hit the same issue

Version-Release number of selected component:
Red Hat Enterprise Linux Server release 6.4 (Santiago)
qemu-kvm-rhev-0.12.1.2-2.359.el6.x86_64
kernel-2.6.32-369.el6.x86_64
virtio-win-prewhql-49

Comment 8 lijin 2013-04-17 02:24:29 UTC
(In reply to comment #7)
> test on version virtio-win-prewhql-49 also hit the same issue
> 
> Version-Release number of selected component:
> Red Hat Enterprise Linux Server release 6.4 (Santiago)
> qemu-kvm-rhev-0.12.1.2-2.359.el6.x86_64
> kernel-2.6.32-369.el6.x86_64
> virtio-win-prewhql-49

my mistake,the version of virtio-win I tested is virtio-win-prewhql-54 instead of virtio-win-prewhql-49

Comment 14 lijin 2013-06-21 07:25:36 UTC
Reproduced this issue on build 49
Verified this issue on build 64

steps same as comment #0

Actual Results:
on build 49, Network fail to access remote computer with error dialogue prompt "Windows can not access \\10.66.73.47".

on build 64 ,Network can access to remote computer and do copy operation.

Based on above ,this issue has been fixed already .

Comment 15 lijin 2013-06-21 09:02:09 UTC
retest this issue on build 65,guest can access to remote computer with  "TestOnly.UseSwTxChecksum" enabled.

So this issue has been fixed.

Comment 16 Mike Cao 2013-06-21 09:07:36 UTC
Move status to VERIFIED according to comment #14&comment #15

Comment 19 errata-xmlrpc 2013-11-22 00:00:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.