Bug 889485 - AMQP defaults are inconsistent
AMQP defaults are inconsistent
Status: CLOSED DUPLICATE of bug 887822
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bob Kukura
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 06:22 EST by Zane Bitter
Modified: 2014-02-27 18:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-21 10:27:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zane Bitter 2012-12-21 06:22:44 EST
Nova uses the Qpid AMQP driver by default as the RPC backend, but Quantum uses the Kombu (RabbitMQ) driver which is the upstream default. The Quantum default should be changed to Qpid also, since that is the supported AMQP implementation.
Comment 2 Alan Pevec 2012-12-21 08:17:04 EST
Indeed, quantum.conf distributed in RPM doesn't set rpc_backend, so cfg default applies, quantum.openstack.common.rpc.impl_kombu

But quantum-{node|dhcp|server}-setup scripts do set rpc_backend to quantum.openstack.common.rpc.impl_qpid along with qpid_hostname.

Anyway, I agree we should make configs consistent out of the box.
Comment 3 Alan Pevec 2012-12-21 10:27:32 EST

*** This bug has been marked as a duplicate of bug 887822 ***

Note You need to log in before you can comment on or make changes to this bug.