This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 889554 - exempi 2.2.0-4 not built with $RPM_*_FLAGS
exempi 2.2.0-4 not built with $RPM_*_FLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: exempi (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2012-12-21 12:34 EST by Ville Skyttä
Modified: 2013-02-19 22:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 12:20:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix mentioned issues (781 bytes, patch)
2012-12-21 12:34 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2012-12-21 12:34:37 EST
Created attachment 667315 [details]
Fix mentioned issues

http://kojipkgs.fedoraproject.org//packages/exempi/2.2.0/4.fc19/data/logs/x86_64/build.log

The changes made in 2.2.0-4 result in $RPM_OPT_FLAGS not being used, fix attached. While at it, use $RPM_LD_FLAGS too, and make the build verbose so it'll be easier to see what exactly was done.
Comment 1 Stanislav Ochotnicky 2013-01-02 04:59:53 EST
Bah, I committed wrong version actually. It is enough to change CPPFLAGS only and thus no overwriting of RPM_OPT_FLAGS would happen
Comment 2 Fedora Update System 2013-01-02 06:57:52 EST
exempi-2.2.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/exempi-2.2.0-5.fc18
Comment 3 Ville Skyttä 2013-01-02 10:29:14 EST
(In reply to comment #1)
> It is enough to change CPPFLAGS
> only and thus no overwriting of RPM_OPT_FLAGS would happen

Looks like the bit that adds $RPM_LD_FLAGS to LDFLAGS is still missing from 2.2.0-5.fc18, see patch in comment 1. I wonder if things wouldn't work just fine if the whole LDFLAGS=... arg to %configure was just simply dropped; without taking a closer look -L%{_libdir} sounds superfluous.
Comment 4 Fedora Update System 2013-01-02 15:19:08 EST
Package exempi-2.2.0-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exempi-2.2.0-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0071/exempi-2.2.0-5.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-02-01 12:20:27 EST
exempi-2.2.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-02-04 05:05:35 EST
exempi-2.2.0-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/exempi-2.2.0-6.fc18
Comment 7 Stanislav Ochotnicky 2013-02-04 05:06:36 EST
(In reply to comment #3)
> (In reply to comment #1)
> > It is enough to change CPPFLAGS
> > only and thus no overwriting of RPM_OPT_FLAGS would happen
> 
> Looks like the bit that adds $RPM_LD_FLAGS to LDFLAGS is still missing from
> 2.2.0-5.fc18, see patch in comment 1. I wonder if things wouldn't work just
> fine if the whole LDFLAGS=... arg to %configure was just simply dropped;
> without taking a closer look -L%{_libdir} sounds superfluous.

You were right of course, I just wanted to get the other bugfix into stable first. Doing a respin with hopefully correct flags this time
Comment 8 Fedora Update System 2013-02-19 22:57:16 EST
exempi-2.2.0-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.