Bug 889557 - Need extra yum repolist in subscription manager section
Need extra yum repolist in subscription manager section
Status: CLOSED DUPLICATE of bug 889306
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
high Severity high
: rc
: 2.1
Assigned To: Bruce Reeler
ecs-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 12:50 EST by Perry Myers
Modified: 2014-10-30 18:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-22 21:57:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2012-12-21 12:50:29 EST
Description of problem:

In section 1.1 of the doc for Repository Configuration, the steps are roughly as follows:

1. sudo subscription-manager register
2. sudo subscription-manager list --available
3. sudo subscription-manager subscribe --pool=POOLID
4. sudo yum-config-manager --disable rhel-server-ost-6-preview-rpms
5. sudo yum-config-manager --enable rhel-server-ost-6-folsom-rpms
6. sudo yum-config-manager --enable rhel-6-server-beta-rpms
7. sudo yum repolist

This set of steps will fail for most people, because /etc/yum.repos.d/redhat.repo is not populated with repositories until after the first yum repolist command is run.  So the yum-config-manager steps in 4/5/6 end up being ineffective, since there is no yum repo configuration for them to act on.

Instead we need an extra step here:
3.5. sudo yum repolist

Inserting the yum repolist here will populate the redhat.repo file, and then the subsequent yum-config-manager steps will have effect.

Also, we should provide sample output for each of the yum repolist commands so that folks know what to expect at each step from yum repolist.

It should look like this:

repo id                       repo name                                   status
rhel-6-server-beta-rpms       Red Hat Enterprise Linux 6 Server Beta (RPMs)1,103
rhel-6-server-rpms            Red Hat Enterprise Linux 6 Server (RPMs)     8,770
rhel-server-ost-6-folsom-rpms Red Hat OpenStack Folsom Preview (RPMs)      138
repolist: 11,066

(Note, I omitted a bunch of other irrelevant repos, the above three are the ones to make sure that are present)

It should also be noted that the output of yum-config-manager --enable should be to show the configuration for the repository that you just enabled.  For example, yum-config-manager --enable on the RHEL 6.4 beta repo shows this:

========================================================================================== repo: rhel-6-server-beta-rpms ==========================================================================================
[rhel-6-server-beta-rpms]
bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/6Server
baseurl = https://cdn.redhat.com/content/beta/rhel/server/6/6Server/x86_64/os
cache = 0
cachedir = /var/cache/yum/x86_64/6Server/rhel-6-server-beta-rpms
cost = 1000
enabled = True
enablegroups = True
exclude = 
failovermethod = priority
gpgcadir = /var/lib/yum/repos/x86_64/6Server/rhel-6-server-beta-rpms/gpgcadir
gpgcakey = 
gpgcheck = True
gpgdir = /var/lib/yum/repos/x86_64/6Server/rhel-6-server-beta-rpms/gpgdir
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,
   file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
hdrdir = /var/cache/yum/x86_64/6Server/rhel-6-server-beta-rpms/headers
http_caching = all
includepkgs = 
keepalive = True
mdpolicy = group:primary
mediaid = 
metadata_expire = 86400
metalink = 
mirrorlist = 
mirrorlist_expire = 86400
name = Red Hat Enterprise Linux 6 Server Beta (RPMs)
old_base_cache_dir = 
password = 
persistdir = /var/lib/yum/repos/x86_64/6Server/rhel-6-server-beta-rpms
pkgdir = /var/cache/yum/x86_64/6Server/rhel-6-server-beta-rpms/packages
proxy = 
proxy_dict = 
proxy_password = 
proxy_username = 
repo_gpgcheck = False
retries = 10
skip_if_unavailable = False
ssl_check_cert_permissions = True
sslcacert = /etc/rhsm/ca/redhat-uep.pem
sslclientcert = /etc/pki/entitlement/4625270554705102875.pem
sslclientkey = /etc/pki/entitlement/4625270554705102875-key.pem
sslverify = True
throttle = 0
timeout = 30.0
username =
Comment 1 Perry Myers 2012-12-22 21:57:53 EST

*** This bug has been marked as a duplicate of bug 889306 ***

Note You need to log in before you can comment on or make changes to this bug.