This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 889570 - Add help / instruction text for custom spoke
Add help / instruction text for custom spoke
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-12-21 13:54 EST by Adam Williamson
Modified: 2013-01-02 16:49 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.37.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 16:49:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-12-21 13:54:57 EST
As a sop for the various discoverability issues with custom part as it stands, dlehman is working on a help screen for it. Filing this bug and proposing as NTH so we can add it into the next anaconda build.
Comment 1 Steve Tyler 2012-12-21 16:04:50 EST
[PATCH 5/6] Add help text and a help button to the custom storage spoke. (#889570)
https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-December/002620.html

"... the lay of the land."

    1. This expression is idiomatic English. Will it make translation difficult?

+2. Click on the "Customize" expander in the mountpoint customization area on the right-hand side of the screen.

    2. What is an "expander"?
    3. "mountpoint" should be "mount point".

+3. Activate the "Reformat" checkbutton, select a filesystem type and, if applicable, enter a mountpoint above in the "Mountpoint" text entry area.

    4. "checkbutton" should be "check box".

+How to set a mountpoint for a filesystem that already exists on your disk

    5. "filesystem" is not English.
Comment 2 Steve Tyler 2012-12-21 16:16:18 EST
(In reply to comment #1)
...
> +3. Activate the "Reformat" checkbutton, select a filesystem type and, if
> applicable, enter a mountpoint above in the "Mountpoint" text entry area.
> 
>     4. "checkbutton" should be "check box".

      4a. "Activate" should be "Click". (If you are using a mouse, anyway.)
Comment 3 Steve Tyler 2012-12-21 16:29:43 EST
+Tips and hints

You can enter sizes as decimal fractions, such as "1.2 GB".
The size units can be ... [including GB and GiB].
Units are not case-sensitive.
If no units are specified for a size, the units are MB.
Comment 4 Adam Williamson 2012-12-21 16:43:46 EST
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Accepted as NTH, obviously it's good to provide some help for people here.
Comment 5 Steve Tyler 2012-12-21 17:34:10 EST
+When you remove the last device from a container device like an LVM volume group, we will automatically remove that container device to make room for new devices.

The term "container" is not used anywhere in the storage UI that I have seen.

AFAIK, volume groups are not devices. (The man pages for vgcreate and vgs do not refer to volume groups as devices.)

If I follow the logic as given, my disk drive is ultimately removed, because it is a container for partitions. :-)

Maybe someone in documentation should review all of this ...
Comment 6 Fedora Update System 2012-12-21 18:32:34 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20838/dracut-024-17.git20121220.fc18,anaconda-18.37.7-1.fc18
Comment 7 Brian Lane 2012-12-22 14:46:55 EST
*** Bug 889622 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-01-02 16:49:30 EST
dracut-024-17.git20121220.fc18, anaconda-18.37.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.