Bug 889574 - Test case failure: multihead test on W530 using intel video
Summary: Test case failure: multihead test on W530 using intel video
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 960058
TreeView+ depends on / blocked
 
Reported: 2012-12-21 19:06 UTC by Vasiliy Sharapov
Modified: 2013-09-23 07:52 UTC (History)
2 users (show)

(edit)
Red Hat Enterprise Linux 6 graphics stacs does not support NVIDIA Optimus hardware configurations. On laptops with both Intel and NVIDIA GPUs, some or all external video ports may not function correctly when using the Intel GPU. If external video ports are needed, configure the BIOS to use the NVIDIA GPU instead of the Intel GPU if possible.
Clone Of:
(edit)
Last Closed: 2013-05-22 13:46:40 UTC


Attachments (Terms of Use)

Description Vasiliy Sharapov 2012-12-21 19:06:25 UTC
NOTE: This only affects the W530 when the BIOS is set to use the integrated Intel graphics. All outputs work when the discrete nV device is enabled instead.
NOTE #2: This bug may be similar to https://bugzilla.redhat.com/show_bug.cgi?id=876295

Filed from caserun https://tcms.engineering.redhat.com/run/50331/#caserun_1764960

Version-Release number of selected component (if applicable):
RHEL6.4-20121026.n.0

Steps to Reproduce: 
 1. Connect as many displays as you can to the available ports on your display
    adapter.
 2. Ensure the 'nomodeset' kernel parameters are not set in your bootloader
    configuration.
 3. Ensure the file /etc/X11/xorg.conf does not exist, or is a valid file that
    uses the valid driver.


 1. Verify that the graphical environment starts correctly and is spanned
    across all connected displays
 2. Open a console and run the command xrandr. Take a copy of the results.
 3. Disconnect and then re-connect one or more displays; do this several times.
    If you are using a docking station for a laptop, try removing the laptop
    from and restoring the laptop to it several times.
 4. Run your gnome-display-properties. Verify that it correctly shows each of
    the connected displays (monitors). Test re-arranging, enabling, disabling
    and configuring displays.



Actual results: 
Multihead appears not to work on W530 when using intel graphics, neither the VGA nor the DisplayPort connections do anything. I'm not sure if this is normal, because I know on another W5## laptop I was playing with (outside of work) I found out that at least in the Win7 environment only the nV device can drive the external ports. So maybe this is not a bug. BUT, xrandr mentions a "VGA1 disconnected" along with LVDS, so now I don't know what is right.

Expected results:
Both X and the graphical environment should cope smoothly with displays being
disconnected and reconnected while the system is running: the displays should
be correctly added or removed by X, and the graphical environment should
correctly adjust itself to the added or removed display

Configuration tools should allow you to arrange the displays in any
configuration, enable and disable displays, and change each display's settings;
these changes should work and be reflected in what each display actually shows

Comment 2 RHEL Product and Program Management 2012-12-25 06:49:40 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 Adam Jackson 2013-05-22 13:46:40 UTC
This is somewhere between a hardware and a software issue.  At any rate it's known and not likely to be fixed any time soon, as switching between the two GPUs on the fly isn't really functional even upstream.

Adding doc text (although I have no idea what 'Result' is meant to be) and closing.


Note You need to log in before you can comment on or make changes to this bug.