This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 889608 - TypeError: not enough arguments for format string
TypeError: not enough arguments for format string
Status: CLOSED DUPLICATE of bug 885139
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e534de7fc8bd341d9487ffca144...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 15:53 EST by Nicolas Chauvet (kwizart)
Modified: 2013-01-07 07:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 07:17:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (371.33 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: anaconda.log (8.58 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: environ (836 bytes, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: ifcfg.log (1.43 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: ks.cfg (2.46 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: packaging.log (9.28 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: program.log (54.80 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: storage.log (118.20 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details
File: syslog (121.24 KB, text/plain)
2012-12-21 15:54 EST, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-12-21 15:53:50 EST
Description of problem:
Error on kickstart installation with only F18-TC3 dvd as media (no repo)
The following was filed automatically by anaconda:
anaconda 18.37.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
  File "/usr/lib64/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib64/python2.7/logging/__init__.py", line 723, in format
    return fmt.format(record)
  File "/usr/lib64/python2.7/logging/handlers.py", line 791, in emit
    msg = self.format(record) + '\000'
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda_log.py", line 114, in emit
    SysLogHandler.emit(self, record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 748, in handle
    self.emit(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1308, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1258, in _log
    self.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1184, in critical
    self._log(CRITICAL, msg, args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3693, in selectGroup
    self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1056, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1183, in _applyYumSelections
    self._selectYumGroup(group.name, default=default, optional=optional)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1213, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1298, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 124, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: not enough arguments for format string

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2018-TC3\x20x86_64 quiet ks=http://haderach.kwizart.net/pub/basic/nchauvet-laptop.ks BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.3
product:        Fedora
release:        Cannot get release name.
type:           libreport
version:        18-TC3
Comment 1 Nicolas Chauvet (kwizart) 2012-12-21 15:54:14 EST
Created attachment 667425 [details]
File: anaconda-tb
Comment 2 Nicolas Chauvet (kwizart) 2012-12-21 15:54:16 EST
Created attachment 667426 [details]
File: anaconda.log
Comment 3 Nicolas Chauvet (kwizart) 2012-12-21 15:54:18 EST
Created attachment 667427 [details]
File: environ
Comment 4 Nicolas Chauvet (kwizart) 2012-12-21 15:54:20 EST
Created attachment 667428 [details]
File: ifcfg.log
Comment 5 Nicolas Chauvet (kwizart) 2012-12-21 15:54:22 EST
Created attachment 667429 [details]
File: ks.cfg
Comment 6 Nicolas Chauvet (kwizart) 2012-12-21 15:54:24 EST
Created attachment 667430 [details]
File: packaging.log
Comment 7 Nicolas Chauvet (kwizart) 2012-12-21 15:54:27 EST
Created attachment 667431 [details]
File: program.log
Comment 8 Nicolas Chauvet (kwizart) 2012-12-21 15:54:30 EST
Created attachment 667432 [details]
File: storage.log
Comment 9 Nicolas Chauvet (kwizart) 2012-12-21 15:54:33 EST
Created attachment 667433 [details]
File: syslog
Comment 10 Zdeněk Pavlas 2013-01-07 07:17:26 EST

*** This bug has been marked as a duplicate of bug 885139 ***

Note You need to log in before you can comment on or make changes to this bug.