Bug 88964 - AddDefaultCharset has wrong default value
AddDefaultCharset has wrong default value
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 15:48 EDT by Noa Resare
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version: 2.0.45-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 04:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2003-04-15 15:48:12 EDT
Description of problem:

Apache as distributed in redhat 9 has the parameter AddDefaultCharset set to
iso-8859-1. This is strange because the system default charset is UTF-8, which
means that if I open a text/html or text/plain file with a text editor and add
some non-ascii characters they will appear broken to the client (except if I
rename the file .html.utf-8 or such) unless the file is first converted to
latin-1 by iconv or some other tool.

I'm all for having a AddDefaultCharset statement but please let it have thev
value UTF-8

Version-Release number of selected component (if applicable):
httpd-2.0.40-21.1

How reproducible:
always

Steps to Reproduce:
1. edit for example /var/www/error/noindex.html and add som non-ascii characters
using your favourite text editor

2. start up the httpd
3. access the page through any browser and watch your non-ascii characters
displayed wrong
4. Try to fix the problem the ususal way, by adding a meta tag or an xml
declaration with no luck and fail
Comment 1 Joe Orton 2003-04-16 11:35:36 EDT
Yes, thanks for reporting this.
Comment 2 Joe Orton 2003-05-18 15:00:16 EDT
UTF-8 is now the default charset in httpd-2.0.45-4.

Note You need to log in before you can comment on or make changes to this bug.