Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 889668 - Iphone 3GS not mounted by Fedora 17 with Xfce Desktop
Summary: Iphone 3GS not mounted by Fedora 17 with Xfce Desktop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: usbmuxd
Version: 17
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-22 12:15 UTC by CLARO
Modified: 2012-12-28 21:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-28 21:17:22 UTC
Type: Bug


Attachments (Terms of Use)

Description CLARO 2012-12-22 12:15:24 UTC
Description of problem:
Iphone 3GS is not mounted on Fedora 17 when connected via a standard USB cable.
This is the same problem reported by BUG #815491 which is in status "CLOSED" but to me, should not be.When the Iphone is connected to the USB port it seems detected but then nothing else happens. I Cannot acces have to my pictures on my Iphone because the File manager does not see the Iphone File system.
I'm using Xfce instead of Gnome3. 
Any Idea to help ?
Thank you.
Version-Release number of selected component (if applicable):
Fedora 17 kernel 3.6.8-2.fc17.x86_64
Xfce 4
usbmuxd usbmuxd-1.0.8-2.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1.install Fedora 17 with Xfce xdesktop 
2.connect an Iphone 3GS IOS 5.1 to an USB port using a standard apple iphone cable
3.
  
Actual results: 
dmesg info :
[ 5254.216068] ipheth 1-3:4.2: Apple iPhone USB Ethernet now disconnected
[ 5256.999056] usb 1-3: new high-speed USB device number 8 using ehci_hcd
[ 5257.119024] usb 1-3: New USB device found, idVendor=05ac, idProduct=1294
[ 5257.119030] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5257.119035] usb 1-3: Product: iPhone
[ 5257.119038] usb 1-3: Manufacturer: Apple Inc.
[ 5257.119042] usb 1-3: SerialNumber: 8cbc376ab4b2130bb9ccb6c9419864f56182e598
[ 5257.349175] ipheth 1-3:4.2: Apple iPhone USB Ethernet device attached
[ 5258.783037] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready


Expected results:
Iphone Icon on the desktop and Iphone Filesystem shown in the filemanager.


Additional info:
Same thing done on the same computer under UBUNTU 12.04 works perfectly !
Iphone is detected ans Iphone FS mounted.

Comment 1 Peter Robinson 2012-12-23 12:00:23 UTC
Have you got ifuse installed. It works fine for a number of other iDevices and the 3GS isn't exactly new

Comment 2 CLARO 2012-12-23 19:58:50 UTC
(In reply to comment #1)
> Have you got ifuse installed. It works fine for a number of other iDevices
> and the 3GS isn't exactly new
Hi Peter,
Thank you for your help. Yes  ifuse-1.1.2-1.fc17.x86_64 is installed. I also installed Gigolo which shows the iphone icon when it is plugged in, but then Gigolo gives a strange URI : afc://*** lot of digits ** for the Iphone. 
What does this mean ? It looks like there is no mount applet available with XFce desktop as there is one in Ubuntu / gnome .
Nothing shows up on my desktop and I'm not able to browse my Iphone directories.
In both cases ( Fedora and Ubuntu ) NetworkManager shows that there is an Apple Iphone on the Wired Network.
After spending hours and hours searching the Internet I still don't have any fix.

Norb.

Comment 3 Peter Robinson 2012-12-23 20:21:15 UTC
got gvfs-afc installed? You shouldn't need any mount applet as it should just automount

Comment 4 CLARO 2012-12-24 00:12:21 UTC
(In reply to comment #3)
> got gvfs-afc installed? You shouldn't need any mount applet as it should
> just automount

Yes,  gvfs-afc-1.12.3-1.fc17.x86_64 is installed. There is something strange on my laptop , there is no eth0 network interface , I have a p35p1 interface instead ( ?? ).
Here is the result on ip addr :
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: p35p1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 48:5b:39:24:bd:76 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 1c:4b:d6:a1:b8:de brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.35/24 brd 192.168.1.255 scope global wlan0
    inet6 fe80::1e4b:d6ff:fea1:b8de/64 scope link 
       valid_lft forever preferred_lft forever

In fact I do not use my Ethernet connector at all since may laptop is connected via a wireless link . Does that matters ??

Another info I've found on the Internet is about thunar, here is the thing
at http://www.uvena.de/gigolo/help.html

"Open resources in Thunar on Xfce 4.4 and 4.6

By default, Gigolo uses gvfs-open to open the connected remote resources. On some systems this will either result in an error or open the wrong file manager because gvfs-open uses the mime types to determine which application it should launch and those mime types are often not configured properly.

First, you need to install the gvfs-fuse backend for GVFS and fuse-utils so that gvfs mounts the remote resources in ~/.gvfs. Make sure that your user is in the fuse group or this will not work. "

I tried to install gvfs-fuse and fuse-utils with yum , but it didn't find any of those !! and more : there is no fuse group in Fedora 17 ! 

Anyway thank you for your fast replies , and merry christmas to you.

Norb.

Comment 5 Peter Robinson 2012-12-24 08:34:46 UTC
The p35p1 is consistent network interface naming, it is as expected and fine. It won't have any effect what so ever.

I have no idea above Xfce and I've only uses it a little. I suspect the issue is with how it deals with the load. It all seems fine to me from the libimobiledevice / usbmuxd PoV

Comment 6 CLARO 2012-12-25 20:51:20 UTC
(In reply to comment #5)
> The p35p1 is consistent network interface naming, it is as expected and
> fine. It won't have any effect what so ever.
> 
> I have no idea above Xfce and I've only uses it a little. I suspect the
> issue is with how it deals with the load. It all seems fine to me from the
> libimobiledevice / usbmuxd PoV

Hi, Peter,
Hope you had a merry christmas.
just to say that my problem is still open and, like you,I do not see what's wrong in this Xfce desktop and its applications! I took my time and moved back to a Standard Fedora 17 with Gnome3 and desktop session gnome-fallback. Everything works fine,my Iphone is mounted and I can view or download my pictures from it.
This is just fine to me.
Anyway , thank you for your help!
Regards, Norb.

Comment 7 Peter Robinson 2012-12-28 21:17:22 UTC
Not a bug with the libimobiledevice components


Note You need to log in before you can comment on or make changes to this bug.