Bug 889718 - [abrt] qemu-system-arm-1.2.2-1.fc18: hw_error: Process /usr/bin/qemu-system-arm was killed by signal 6 (SIGABRT)
[abrt] qemu-system-arm-1.2.2-1.fc18: hw_error: Process /usr/bin/qemu-system-a...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
abrt_hash:0e2ba426ceb7e933344a7bb023f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 17:14 EST by Michael Scherer
Modified: 2013-09-09 10:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 10:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (15.81 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: cgroup (127 bytes, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: core_backtrace (779 bytes, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: dso_list (7.68 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: environ (2.10 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: maps (38.14 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: open_fds (497 bytes, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: proc_pid_status (910 bytes, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: smolt_data (3.66 KB, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details
File: var_log_messages (557 bytes, text/plain)
2012-12-22 17:14 EST, Michael Scherer
no flags Details

  None (edit)
Description Michael Scherer 2012-12-22 17:14:30 EST
Description of problem:
trying to start qemu-system-arm with debian wheezy kernel

Version-Release number of selected component:
qemu-system-arm-1.2.2-1.fc18

Additional info:
backtrace_rating: 3
cmdline:        qemu-system-arm -kernel /tmp/vmlinuz-3.2.0-4-versatile -initrd /tmp/initrd.gz /dev/mmcblk0p1
crash_function: hw_error
executable:     /usr/bin/qemu-system-arm
kernel:         3.6.11-3.fc18.x86_64
remote_result:  NOTFOUND
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 hw_error at /usr/src/debug/qemu-kvm-1.2.0/cpus.c:405
 #3 integratorcm_read at /usr/src/debug/qemu-kvm-1.2.0/hw/integratorcp.c:105
 #5 memory_region_read_accessor at /usr/src/debug/qemu-kvm-1.2.0/memory.c:314
 #6 access_with_adjusted_size at /usr/src/debug/qemu-kvm-1.2.0/memory.c:359
 #7 memory_region_dispatch_read1 at /usr/src/debug/qemu-kvm-1.2.0/memory.c:872
 #8 memory_region_dispatch_read at /usr/src/debug/qemu-kvm-1.2.0/memory.c:904
 #9 io_mem_read at /usr/src/debug/qemu-kvm-1.2.0/memory.c:1508
 #10 io_readb at /usr/src/debug/qemu-kvm-1.2.0/softmmu_template.h:80
 #11 helper_ldb_mmu at /usr/src/debug/qemu-kvm-1.2.0/softmmu_template.h:116
 #12 ??
Comment 1 Michael Scherer 2012-12-22 17:14:34 EST
Created attachment 667845 [details]
File: backtrace
Comment 2 Michael Scherer 2012-12-22 17:14:36 EST
Created attachment 667846 [details]
File: cgroup
Comment 3 Michael Scherer 2012-12-22 17:14:42 EST
Created attachment 667847 [details]
File: core_backtrace
Comment 4 Michael Scherer 2012-12-22 17:14:44 EST
Created attachment 667848 [details]
File: dso_list
Comment 5 Michael Scherer 2012-12-22 17:14:46 EST
Created attachment 667849 [details]
File: environ
Comment 6 Michael Scherer 2012-12-22 17:14:47 EST
Created attachment 667850 [details]
File: limits
Comment 7 Michael Scherer 2012-12-22 17:14:50 EST
Created attachment 667851 [details]
File: maps
Comment 8 Michael Scherer 2012-12-22 17:14:52 EST
Created attachment 667852 [details]
File: open_fds
Comment 9 Michael Scherer 2012-12-22 17:14:54 EST
Created attachment 667853 [details]
File: proc_pid_status
Comment 10 Michael Scherer 2012-12-22 17:14:56 EST
Created attachment 667854 [details]
File: smolt_data
Comment 11 Michael Scherer 2012-12-22 17:14:58 EST
Created attachment 667855 [details]
File: var_log_messages
Comment 12 Cole Robinson 2013-09-09 10:02:59 EDT
F19 qemu-system-arm with those debian kernel/initrd works for me if I add the -M versatilepb switch. Again this is an example of crappy qemu-system-arm error reporting, but as mentioned in the other bug it's unlikely to be fixed anytime soon, so closing as WORKSFORME WRT the initial crash

Note You need to log in before you can comment on or make changes to this bug.