Bug 889727 - FormatDestroyError: error wiping old signatures from /dev/sda2: 1
FormatDestroyError: error wiping old signatures from /dev/sda2: 1
Status: CLOSED DUPLICATE of bug 896635
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:32b8f3aaf44d24ab2463f91f32a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 19:23 EST by Chris Murphy
Modified: 2013-02-04 08:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 896635
Environment:
Last Closed: 2013-02-04 08:40:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (36.80 KB, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: environ (885 bytes, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: ifcfg.log (697 bytes, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: messages (415.54 KB, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: packaging.log (144 bytes, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: program.log (163.49 KB, text/plain)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: anaconda-tb (1.77 MB, application/octet-stream)
2012-12-22 19:23 EST, Chris Murphy
no flags Details
File: storage.log (1.10 MB, application/octet-stream)
2012-12-22 19:23 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-22 19:23:16 EST
Description of problem:
1. Installation Destination > Choose 6 disks previously used by anaconda of same version, with "guided" autopartitioning Btrfs.
2. Manual Partitioning > Delete all partitions/subvols
3. Add Root, set to Btrfs.
4. Finish.
5. Begin installation
Crash
The following was filed automatically by anaconda:
anaconda 18.37.8 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 322, in destroy
    raise FormatDestroyError(msg)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 4169, in _destroy
    DeviceFormat(device=device.path, exists=True).destroy()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 818, in destroy
    self._destroy()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 286, in execute
    self.device.destroy()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 323, in processActions
    action.execute()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 323, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 174, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 114, in doInstall
    turnOnFilesystems(storage)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
FormatDestroyError: error wiping old signatures from /dev/sda2: 1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-18-TC3-x86_64-Live-Deskto rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: python-libs-2.7.3-13.fc18.x86_64
package:        anaconda-18.37.8-1.fc18.x86_64
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Chris Murphy 2012-12-22 19:23:19 EST
Created attachment 667892 [details]
File: anaconda.log
Comment 2 Chris Murphy 2012-12-22 19:23:21 EST
Created attachment 667893 [details]
File: environ
Comment 3 Chris Murphy 2012-12-22 19:23:23 EST
Created attachment 667894 [details]
File: ifcfg.log
Comment 4 Chris Murphy 2012-12-22 19:23:25 EST
Created attachment 667895 [details]
File: messages
Comment 5 Chris Murphy 2012-12-22 19:23:26 EST
Created attachment 667896 [details]
File: packaging.log
Comment 6 Chris Murphy 2012-12-22 19:23:28 EST
Created attachment 667897 [details]
File: program.log
Comment 7 Chris Murphy 2012-12-22 19:23:38 EST
Created attachment 667898 [details]
File: anaconda-tb
Comment 8 Chris Murphy 2012-12-22 19:23:42 EST
Created attachment 667899 [details]
File: storage.log
Comment 9 Chris Murphy 2012-12-22 19:27:55 EST
Immediately after the crash, relaunched anaconda and tried again with the same steps as above. No crash this time, installation commences.
Comment 10 Samantha N. Bueno 2013-02-04 08:40:22 EST

*** This bug has been marked as a duplicate of bug 896635 ***

Note You need to log in before you can comment on or make changes to this bug.