Bug 889734 - In package fedora-kickstarts-0.18.2-1.fc18.noarch, kickstart file /usr/share/spin-kickstarts/fedora-live-kde-base.ks references non-existent package
In package fedora-kickstarts-0.18.2-1.fc18.noarch, kickstart file /usr/share/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
18
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 21:11 EST by M. Edward (Ed) Borasky
Modified: 2013-01-10 00:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-10 00:43:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch that allows successful ISO creation on my machine (341 bytes, patch)
2012-12-23 01:15 EST, M. Edward (Ed) Borasky
no flags Details | Diff

  None (edit)
Description M. Edward (Ed) Borasky 2012-12-22 21:11:45 EST
Description of problem:

I'm building ISOs from kickstart files. I've got a kickstart file that depends on /usr/share/spin-kickstarts/fedora-live-kde-base.ks. This file has the lines:

# use system-config-printer-kde instead of system-config-printer
-system-config-printer
system-config-printer-kde

But when I run the build, it tells me that 'system-config-printer-kde' doesn't exist:

Error creating Live CD : Failed to find package 'system-config-printer-kde' : No package(s) available to install

This looks like the same problem as the one that caused the Fedora Jam nightly build to fail:

http://kojipkgs.fedoraproject.org//work/tasks/3958/4813958/livecd.log
Comment 1 M. Edward (Ed) Borasky 2012-12-23 01:15:57 EST
Created attachment 667940 [details]
Patch that allows successful ISO creation on my machine

Here's a patch I built to make my script run. The whole source tree is in https://github.com/znmeb/AlgoCompSynth/tree/master/LiveImageCreation. The command 'sudo ./install-all' rebuilds the Fedora 18 'Jam' respin on my workstation.
Comment 2 Bill Nottingham 2013-01-02 13:53:46 EST
This was fixed in git in commit a4e37767541530dd483ba7984621dfb67c0ccbb7, looks like a new package needs built?
Comment 3 Bruno Wolff III 2013-01-02 14:10:19 EST
I believe release engineering does a rebuild of spin-kickstarts just before release. The released copy is supposed to have the exact kickstarts used for the release. The git version of the kickstarts get used for release, and there isn't an effective freeze process for those, so rebuilding spin-kickstarts right now wouldn't be that much help. It wouldn't get pulled in before releng would want to do a build.
If for some reason one doesn't get rebuilt for the release images, I'll do an update that as best I can tell is from the point of the release.
Comment 4 Kevin Fenzi 2013-01-02 16:55:49 EST
Well, it's always been you AFAIK doing the final package. ;) 

However, yeah, we usually wait until we know the final gold content and then push a new package. 
It usually goes out as an update, since it's not on any media.
Comment 5 Fedora Update System 2013-01-09 22:56:29 EST
spin-kickstarts-0.18.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spin-kickstarts-0.18.3-1.fc18
Comment 6 Fedora Update System 2013-01-10 00:43:41 EST
spin-kickstarts-0.18.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.