Bug 88975 - latest qla2x00 drivers are 6.04.00
latest qla2x00 drivers are 6.04.00
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
http://www.qlogic.com/support/oem_det...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 17:39 EDT by acount closed by user
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-07 06:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-15 17:39:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:

latest QLogic HBA driver which has undergone EMC qualification for
CLARiiON and Symmetrix are: qla2x00src-v6.04.00-emc.tgz



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.-
2.-
3.-
    

Additional info:
Comment 1 Arjan van de Ven 2003-04-16 04:13:11 EDT
we include something very close to that (which was the latest released at the
time of the update)
Comment 2 acount closed by user 2003-04-16 19:48:55 EDT
more or less close in time, but there are lot of changes.
It would be nice too to update aic7xxx to 6.2.32

--thanks--

--revision.notes-
/*
 * QLogic ISP2200 and ISP2300 Linux Driver Revision List File.
 *
 ********************************************************************
 *
 * Revision History
 *
 *  Rev  6.04.00        January 20, 2003        RA
 *      - Formal release to Compaq
 *
 *  Rev  6.04.00b8      January 16, 2003        RA/DG/AV
 *      - Use proper compiler flags when built with later GCC
 *        versions (3.x).
 *      - Rewrite initiator handling code:
 *        - Use linked lists rather than a fixed-size array.
 *        - Properly logout of intiator devices if found to be lost.
 *        - Changes in qla2x00.c and qla2x00_ioctl.c.
 *      - Fix lun suspension logic:
 *        - Remove code in qla2x00_lun_alloc() which incorrectly
 *          trashes a lun queue's q_count and q_max members.
 *        - Properly move from a lun_queue NOT-ready state to a
 *          ready state when a command successfully completes in
 *          qla2x00_callback().
 *        - Add 'delay' logic to handle throttling scenario required
 *          during a failback operation.
 *      - Return a byte statistical quantity not mega-bytes in
 *        qla2x00_get_(fc_)statistics() -- this change did not go
 *        into 6.03.00b6 as indicated by the release notes.
 *      - Handle a SCSI_DATA_NONE data direction for a SCSI command.
 *
 *  Rev  6.04.00b7      Jan. 10 2003    DG/RA
 *      - Added VMWARE support.
 *      - fixed the bus reset and host reset when issued through
 *        the backdoor by not waiting for commands which we dont own.
 *
 *  Rev  6.04.00b6      Jan. 8 2003     DG/RA
 *      - Fixed hardware_lock hierarchy in qla2x00_cmd_timeout
 *        routine to fix deadlock with interrupt handler.
 *
 *  Rev  6.04.00b5      Jan. 8 2003     DG/AV
 *      - Fix incorrect sizing of mbx_cmd_flags in structure
 *        scsi_qla_host since bit-operators function on unsigned
 *        long variables - in qla2x00.c.
 *
 *  Rev  6.04.00b4      December 19, 2002       RL/RA/DG/AV
 *      - Increase IOCTL-passthru command timeout value (30->60).
 *      - Update local definition of pci_set_dma_mask() to take an
 *        u64 type rather than an dma_addr_t.
 *      - Fix qla2100_nvram_config() to set the high-water IOCB limit
 *        while configuring an QLA2100 HBA.
 *      - Fixed potential panic in qla2x00_failback_luns() routine -
 *        dereference a NULL fclun.
 *
 *  Rev  6.04.00b3      December 06, 2002       AV
 *      - Fix binding algorithm in qla2x00_cfg_build_path_tree() to
 *        support sparse targetIDs.
 *      - Extend maximum number of failover paths to eight.
 *
 *  Rev  6.04.00b2      November 27, 2002       DG/RA/AV
 *      - Pass portID information up to FO_CC_GET_TARGET_DATA ioctl
 *        callers.
 *      - Add support for PortID persistent binding:
 *        - Module parameter name: Bind
 *              o 0 by Portname (default)
 *              o 1 by PortID
 *              o 2 by Nodename
 *        - Default behaviour is to bind by Portname.
 *        - Update qla2x00_display_fc_names() to support new binding
 *          methods -- varies by Bind type.
 *        - Large #defing usage cleanup to more flexible module
 *          parameter.
 *      - Use various PCI/SCSI/endianess macros defined by the kernel
 *        to reduce duplication.
 *      - Streamline qla2x00_response_packet():
 *        - Reduce multiple Register I/O writes to just one after
 *          ring processing.
 *      - Cleanup qla2x00_status_entry():
 *        - Move common cases to the top of the switch statement
 *          (CS_COMPLETE and CS_DATA_UNDERRUN).
 *        - Refine data underrun handling, since it appears the
 *          mid-layer underflow structure member for SCSI commands is
 *          not consistently populated by the various upper-layers.
 *      - Cleanup qla2x00_error_entry() to use pre-defined
 *        descriptive values while interrogating a packet's
 *        entry_status rather than raw BIT_* defines.
 *      - Maintain 'RLC supported' state for an fcport, to limit
 *        extraneous RLC commands.
 *      - Initial qla2x00_isr() sanitization -- formating and
 *        readability.
 *      - In qla2x00_queuecommand(), return a command immediately, if
 *        the port is found to be DEAD.
 *      - Fix a dead-lock (logic) problem in
 *        qla2x00_mailbox_command() where the code would attempt to
 *        acquire a lock which had never been released.
 *      - Add support for status continuation IOCB entries (extended
 *        sense data).
 *      - During loop transition, report back successfully completed
 *        commands rather than blindly retry --
 *        qla2x00_status_entry().
 *      - Export ql2xretrycount as a module parameter.  Default value
 *        in non-failover mode is 20, in failover mode, 30.
 *      - Update Makefile to use 'install' rather than 'cp' as to
 *        preserve uid/gid (Austin Gonyou).
 *      - Consolidate duplicate code to set DMA mask --
 *        qla2x00_config_dma_mask().
 *      - Fix copy-error in qla2x00_send_fo_notification() where the
 *        SCSI CDB would not be populated with the proper
 *        notification CDB.
 *      - In qla2x00_proc_info(), do not clear our buffer in case
 *        another application is using it.
 *      - Export a MODULE parameter, ql2xfailover, to allow failover
 *        to be configured in at load time.
 *
 *          NOTE: Default behaviour is still based on the
 *                compile-time option MPIO_SUPPORT.
 *
 *      - Add additional checks to ensure that the DPC routine has
 *        already been created before trying to 'wake' it up.
 *      - Add new 2300 IP/TP firmware (3.01.18).
 *
 *  Rev  6.04.00b1      November 4, 2002        DG
 *      - Fixed ISP abort retry logic to retry the abort_ISP().
 *      - Fixed port login logic to retry the login on ports that are
 *        marked DEAD.
 *      - Fixed issue of not loging in after loop is down for more than
 *        4 mins.
[..]
--end--
Comment 3 acount closed by user 2003-09-07 06:43:42 EDT
for reference, latest qlogic driver lives at :
http://www.qlogic.com/support/oem_detail_all.asp?oemid=65

Note You need to log in before you can comment on or make changes to this bug.