Bug 889760 - Update to latest sugar bugfix release
Update to latest sugar bugfix release
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-12-23 06:09 EST by Peter Robinson
Modified: 2013-01-10 00:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:34:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
terminal output when running liveinst in sugar root terminal (70.08 KB, image/png)
2013-01-08 08:48 EST, satellitgo
no flags Details

  None (edit)
Comment 1 Adam Williamson 2013-01-02 14:45:41 EST
Discussed at 2013-01-02 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2013-01-02/f18final-blocker-review-8.2013-01-02-17.03.log.txt . Accepted as NTH - would block a release-blocking desktop, so NTH for a non-blocking one.
Comment 2 Fedora Update System 2013-01-04 20:01:35 EST
sugar-artwork-0.98.2-1.fc18, sugar-0.98.2-1.fc18, sugar-datastore-0.98.1-1.fc18, sugar-toolkit-gtk3-0.98.2-1.fc18, sugar-physics-11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20555/sugar-artwork-0.98.2-1.fc18,sugar-0.98.2-1.fc18,sugar-datastore-0.98.1-1.fc18,sugar-toolkit-gtk3-0.98.2-1.fc18,sugar-physics-11-1.fc18
Comment 3 Adam Williamson 2013-01-05 12:59:15 EST
Note that for RC1 we are pulling the fixes listed under "Bugfixes, memory leaks and crashes:" and "Memory leak", but not "Fix cut and paste (might need a gtk3 patch too):" because we're reluctant to poke pygobject3 this late. How badly is cut and paste "broken"? How much would it suck for Sugar if we don't pull those fixes?
Comment 4 satellitgo 2013-01-05 13:41:16 EST
cut and paste in SoaS causes reboot of sugar to gdm. Files saved are saved to sugar-journal and can be seen on restart.
Soas live TC4 x86_64 as dd to USB and Live-iso-to disk USB.
that is how I filed sugarlabs bug 4365 
( drag drop from journal to mounted external USB after reboot)
Comment 5 Peter Robinson 2013-01-05 14:22:51 EST
The pyobject3 patch is very self contained and it fixes one issue on its own, the possible patch for gtk3 fixes another but different issue. http://pkgs.fedoraproject.org/cgit/pygobject3.git/commit/?h=f18&id=ff088ad3ed328ca9ff3fc29755a28ee8d9551337

I can live without the gtk3 fix but the pygobject fix would be very useful and is very self contained.

These are useful even without the above patch too
https://admin.fedoraproject.org/updates/sugar-toolkit-gtk3-0.98.3-1.fc18
https://admin.fedoraproject.org/updates/sugar-0.98.3-1.fc18

I think this one was missed.
https://admin.fedoraproject.org/updates/FEDORA-2012-20754/sugar-paint-54-1.fc18
Comment 6 satellitgo 2013-01-06 14:04:46 EST
systemctl start graphical.target => finishes firstboot but then gdm does not offer a login, only a spinning circle cursor
has returned in Fedora-18-i686-Live-SoaS.iso and x86_64

https://bugzilla.redhat.com/show_bug.cgi?id=828197
Comment 7 Peter Robinson 2013-01-07 15:52:06 EST
can you confirm this is when you do a liveinst of the live disk to HDD and try and boot off that like before or is it a different problem?
Comment 8 satellitgo 2013-01-08 08:48:57 EST
Created attachment 674833 [details]
terminal output when running liveinst in sugar root terminal
Comment 9 Fedora Update System 2013-01-08 16:34:32 EST
sugar-artwork-0.98.2-1.fc18, sugar-datastore-0.98.1-1.fc18, sugar-physics-11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Adam Williamson 2013-01-08 16:38:54 EST
peter: I can confirm the black screen / spinny cursor bug after running liveinst from the live image. Actual live use works fine, DVD install works fine. Not sure how bad a bug this is, I don't know typical usage of the SoaS spin. Aside from that, things work okay. I don't know if this regressed in RC2, I can grab TC4 or RC1 and check in a bit.
Comment 11 Adam Williamson 2013-01-08 16:49:53 EST
ah, satellit mentioned in the other bug that this was broken in RC1, so it's at least not a regression related to the new packages introduced in RC2.
Comment 12 satellitgo 2013-01-10 00:59:10 EST
confirmed in install of RC4 Soas-live x86_64 
finishes firstboot but then gdm does not offer a login, only a spinning circle cursor

Note You need to log in before you can comment on or make changes to this bug.